Commit 5d1a9375 authored by Andreas Jaeger's avatar Andreas Jaeger

Fix testing

Update hacking version so that it works with newer pbr releases, other
requirements depend on newer pbr and this causes a conflict.

Add pbr to requirements since it's needed.

Add pep8 ignore for those tests that currently fail.

Rename oslo.config to oslo_config in imports.

Change-Id: I23c0afa855be4773a8799d09d1cda011e85367bd
parent 06460e0d
......@@ -16,7 +16,7 @@
# under the License.
import fixtures
from oslo.config import cfg
from oslo_config import cfg
import six
......
......@@ -25,7 +25,7 @@ import threading
import time
import weakref
from oslo.config import cfg
from oslo_config import cfg
from climateclient.openstack.common import fileutils
from climateclient.openstack.common.gettextutils import _
......
......@@ -37,7 +37,7 @@ import re
import sys
import traceback
from oslo.config import cfg
from oslo_config import cfg
import six
from six import moves
......
hacking>=0.8.0,<0.9
hacking>=0.10.2,<0.11
discover
mock>=1.0
mox>=0.5.3
......
......@@ -19,6 +19,8 @@ commands = flake8
[flake8]
show-source = true
builtins = _
# Ignore currently failing tests for now
ignore = E265,H405
exclude=.venv,.git,.tox,dist,doc,*openstack/common*,*lib/python*,*egg
[testenv:venv]
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment