test-requirements.txt 528 Bytes
Newer Older
1
# Install bounded pep8/pyflakes first, then let flake8 install
2 3 4 5
pep8==1.5.7
pyflakes==0.8.1
flake8>=2.2.4,<=2.4.1
hacking>=0.10.0,<0.11
6 7 8 9

coverage>=3.6
discover
feedparser
10
fixtures>=0.3.14
11
mock>=1.2
12
mox>=0.5.3
13
psycopg2
14
python-subunit>=0.0.18
15
sphinx>=1.1.2,<1.2
16
sphinxcontrib_issuetracker
17
testrepository>=0.0.17
18
testtools>=0.9.34,<0.9.36
Mike Bayer's avatar
Mike Bayer committed
19
tempest-lib>=0.1.0
20

Cyril Roelandt's avatar
Cyril Roelandt committed
21
scripttest
22 23
# NOTE(rpodolyaka): This version identifier is currently necessary as
#                   pytz otherwise does not install on pip 1.4 or higher
Cyril Roelandt's avatar
Cyril Roelandt committed
24
pylint
25
pytz>=2010h