Commit fe148d87 authored by Sean Dague's avatar Sean Dague

uncap SQLA in requirements.txt

migrate can't just take a global requirements sync because it
needs to be tested against multiple versions of SQLA to assure
compatibility. A recent change had the effect of only testing
migrate against SQLA 0.7, which is definitely *not* what we
want to be doing.

this reverts that change, and leaves very specific comments to
hopefully prevent this from happening in the future.

Change-Id: Icb4e136f0de6caa224019bb955341c4b67c5e1a1
parent d58e47f8
pbr>=0.5.21,<1.0 pbr>=0.5.21,<1.0
SQLAlchemy>=0.7.8,<=0.7.99 # never put a cap on this, *ever*, sqla versions are handled via
# tox, and if SQLA is capped it will only make it so we aren't testing
# against all the versions we are compatible with.
SQLAlchemy>=0.7.8
decorator decorator
Tempita >= 0.4 Tempita >= 0.4
...@@ -12,6 +12,14 @@ deps = -r{toxinidir}/requirements.txt ...@@ -12,6 +12,14 @@ deps = -r{toxinidir}/requirements.txt
commands = commands =
python setup.py testr --slowest --testr-args='{posargs} --concurrency=1' python setup.py testr --slowest --testr-args='{posargs} --concurrency=1'
[testenv:py26]
deps = sqlalchemy>=0.8,<=0.8.99
-r{toxinidir}/test-requirements.txt
[testenv:py27]
deps = sqlalchemy>=0.8,<=0.8.99
-r{toxinidir}/test-requirements.txt
[testenv:py26sa07] [testenv:py26sa07]
basepython = python2.6 basepython = python2.6
deps = sqlalchemy>=0.7,<=0.7.99 deps = sqlalchemy>=0.7,<=0.7.99
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment