Commit 74680aa5 authored by Ben Nemec's avatar Ben Nemec

Support python-requires metadata

Expose the python_require setuptools option via the python-requires
metadata item in setup.cfg.

Closes-Bug: 1735668

Change-Id: Idf2bb90882121e118f5b7531e027d350c0e4a441
Co-authored-by: 's avatarDennis Verspuij <dennisverspuij@users.noreply.github.com>
parent f30aa7a9
......@@ -114,6 +114,7 @@ D1_D2_SETUP_ARGS = {
# broken distutils requires
"install_requires": ("metadata", "requires_dist"),
"setup_requires": ("metadata", "setup_requires_dist"),
"python_requires": ("metadata",),
"provides": ("metadata", "provides_dist"), # **
"obsoletes": ("metadata", "obsoletes_dist"), # **
"package_dir": ("files", 'packages_root'),
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment