Commit 34d541aa authored by Jenkins's avatar Jenkins Committed by Gerrit Code Review

Merge "Fix outdated links and document spelling error"

parents c10e1d52 39ea7f81
# This is a cross-platform list tracking distribution packages needed by tests;
# see http://docs.openstack.org/infra/bindep/ for additional information.
# see https://docs.openstack.org/infra/bindep/ for additional information.
libxml2-devel [test platform:rpm]
libxml2-dev [test platform:dpkg]
......
......@@ -47,7 +47,7 @@
#
# [*ceph_apache_repo*] Whether to require the CEPH apache repo (ceph::repo::fastcgi).
# Optional. Default is true. Check:
# http://ceph.com/docs/master/install/install-ceph-gateway/
# http://docs.ceph.com/docs/master/install/install-ceph-gateway/
# for more info on repository recommendations.
#
# [*apache_mods*] Whether to configure and enable a set of default Apache modules.
......@@ -102,7 +102,7 @@ define ceph::rgw::apache_fastcgi (
include ::apache::mod::rewrite
#Rewrite rule
#Variable name shrinked in favor of not having
#Variable name shrunk in favor of not having
#more than 140 chars per line
$rr = '^/([a-zA-Z0-9-_.]*)([/]?.*) /s3gw.fcgi?page=$1&params=$2&%{QUERY_STRING} [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]'
......
---
features:
- The ceph cluster FSID is explictly added as a cluster option (--cluster-uuid) to ceph-disk prepare per OSD
- The ceph cluster FSID is explicitly added as a cluster option (--cluster-uuid) to ceph-disk prepare per OSD
- An additional check is done prior to preparing an OSD to verify the OSD is not already prepared with a different FSID, which is a symptom of trying to add an OSD from a different ceph cluster
- Prior to this change, a deploy might report it is successful even if all of the OSDs fail to activate. The logs will now indicate that the OSD activation failed because a different FSID was found so that the user may then choose zap away the old deploy
fixes:
......
......@@ -14,7 +14,7 @@ upgrade:
`osd/osd_op_threads`
deprecations:
- ceph::init set_osd_params is added new as deprecated.
This is to support backwards compability in this release.
This is to support backwards compatibility in this release.
It will be removed in the next release. Please inspect your
usage of ceph::conf for `osd/osd_max_backfills`,
`osd_max_scrubs`, `osd/osd_recovery_max_active`,
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment