Commit 92cb2c48 authored by Thomas Goirand's avatar Thomas Goirand

Running tests with all versions of Python 3.

parent 09e8b86e
......@@ -7,6 +7,7 @@ python-django-compressor (2.2-1) unstable; urgency=medium
* Removed build-depends on coffin.
* Added fix-html5lib.serialize-call.patch.
* Added neutralize-broken-test_css_return_if_off-test.patch.
* Running tests with all versions of Python 3.
-- Thomas Goirand <zigo@debian.org> Sat, 28 Oct 2017 20:24:56 +0000
......
......@@ -12,11 +12,10 @@ override_dh_clean:
override_dh_auto_test:
ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
PYTHON=python2 PYTHONPATH=. python-coverage run --branch --source=compressor /usr/bin/django-admin test --settings=compressor.test_settings compressor
rm -rf $(CURDIR)/compressor/tests/static/CACHE
# TODO: make unit tests to work.
PYTHON=python3 PYTHONPATH=. python3-coverage run --branch --source=compressor /usr/bin/django-admin test --settings=compressor.test_settings compressor
rm -rf $(CURDIR)/compressor/tests/static/CACHE
for i in 2.7 $(PYTHON3S) ; do \
PYTHON=python$$i PYTHONPATH=. python$$i -m coverage run --branch --source=compressor /usr/bin/django-admin test --settings=compressor.test_settings compressor ; \
rm -rf $(CURDIR)/compressor/tests/static/CACHE ; \
done
endif
override_dh_auto_build:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment