Commit cab3b363 authored by Thomas Goirand's avatar Thomas Goirand

Removed Python 2 support.

parent b7c62def
python-django-compressor (2.2-5) UNRELEASED; urgency=medium
python-django-compressor (2.2-5) unstable; urgency=medium
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
* Running wrap-and-sort -bast
* d/control: Use team+openstack@tracker.debian.org as maintainer
-- Ondřej Nový <onovy@debian.org> Mon, 12 Feb 2018 10:31:15 +0100
[ Thomas Goirand ]
* Removed Python 2 support.
-- Thomas Goirand <zigo@debian.org> Wed, 10 Jul 2019 11:29:22 +0200
python-django-compressor (2.2-4) unstable; urgency=high
......
......@@ -8,26 +8,10 @@ Build-Depends:
debhelper (>= 10),
dh-python,
openstack-pkg-tools,
python-all,
python-setuptools,
python3-all,
python3-setuptools,
Build-Depends-Indep:
csstidy,
python-bs4,
python-coverage (>= 4.4),
python-csscompressor,
python-django,
python-django-appconf,
python-django-sekizai,
python-html5lib,
python-jinja2,
python-lxml,
python-mock,
python-nose,
python-rcssmin,
python-rjsmin,
python-unittest2,
python3-bs4,
python3-coverage (>= 4.4),
python3-csscompressor,
......@@ -47,23 +31,6 @@ Vcs-Browser: https://salsa.debian.org/openstack-team/python/python-django-compre
Vcs-Git: https://salsa.debian.org/openstack-team/python/python-django-compressor.git
Homepage: https://pypi.python.org/pypi/django_compressor/
Package: python-django-compressor
Architecture: all
Depends:
python-csscompressor,
python-django,
python-django-appconf,
python-rcssmin,
python-rjsmin,
${misc:Depends},
${python:Depends},
Description: Compresses linked, inline JS or CSS into single cached files - Python 2.7
Django Compressor combines and compresses linked and inline Javascript or CSS
in a Django templates into cacheable static files by using the compress
template tag.
.
This package contains the Python 2.7 module.
Package: python3-django-compressor
Architecture: all
Depends:
......
......@@ -4,34 +4,29 @@ UPSTREAM_GIT := https://github.com/django-compressor/django-compressor.git
include /usr/share/openstack-pkg-tools/pkgos.make
%:
dh $@ --buildsystem=python_distutils --with python2,python3
dh $@ --buildsystem=python_distutils --with python3
override_dh_clean:
dh_clean
rm -rf .coverage
override_dh_auto_clean:
rm -rf build .coverage
find . -iname '*.pyc' -delete
for i in $$(find . -type d -iname __pycache__) ; do rm -rf $$i ; done
override_dh_auto_build:
echo "Do nothing..."
override_dh_auto_test:
echo "Do nothing..."
override_dh_auto_install:
pkgos-dh_auto_install --no-py2
ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
for i in 2.7 $(PYTHON3S) ; do \
for i in $(PYTHON3S) ; do \
PYTHON=python$$i PYTHONPATH=. python$$i -m coverage run --branch --source=compressor /usr/bin/django-admin test --settings=compressor.test_settings compressor ; \
rm -rf $(CURDIR)/compressor/tests/static/CACHE ; \
done
endif
override_dh_auto_build:
override_dh_auto_install:
pkgos-dh_auto_install
rm -f $(CURDIR)/debian/usr/lib/python*/dist-packages/compressor/tests/static/CACHE/css/*
rm -f $(CURDIR)/debian/usr/lib/python*/dist-packages/compressor/tests/static/CACHE/js/*
find debian -iname '*.pyc' -delete
# Commands not to run
override_dh_installcatalogs:
override_dh_installemacsen override_dh_installifupdown:
override_dh_installinfo override_dh_installmenu override_dh_installmime:
override_dh_installmodules override_dh_installlogcheck:
override_dh_installpam override_dh_installppp override_dh_installudev override_dh_installwm:
override_dh_installxfonts override_dh_gconf override_dh_icons override_dh_perl:
override_dh_installlogrotate override_dh_installgsettings override_dh_bugfiles override_dh_ucf:
override_dh_installexamples override_dh_installman override_dh_installcron override_dh_installdebconf:
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment