requirements.txt 1.71 KB
Newer Older
1 2 3 4
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.

5
retrying!=1.3.0,>=1.2.3 # Apache-2.0
6 7
jsonpath-rw-ext>=0.1.9 # Apache-2.0
jsonschema!=2.5.0,<3.0.0,>=2.0.0 # MIT
8
kafka-python<1.0.0,>=0.9.5 # Apache-2.0
9
keystonemiddleware!=4.1.0,>=4.0.0 # Apache-2.0
10 11
lxml>=2.3 # BSD
msgpack-python>=0.4.0 # Apache-2.0
12
oslo.context>=0.2.0 # Apache-2.0
13
oslo.db>=4.1.0 # Apache-2.0
14
oslo.concurrency>=3.5.0 # Apache-2.0
15
oslo.config>=3.7.0 # Apache-2.0
16
oslo.i18n>=2.1.0 # Apache-2.0
17
oslo.log>=1.14.0 # Apache-2.0
18
oslo.policy>=0.5.0 # Apache-2.0
19
oslo.reports>=0.6.0 # Apache-2.0
20
oslo.rootwrap>=2.0.0 # Apache-2.0
21
oslo.service>=1.0.0 # Apache-2.0
22 23 24
PasteDeploy>=1.5.0 # MIT
pbr>=1.6 # Apache-2.0
pecan>=1.0.0 # BSD
25
oslo.messaging>=4.0.0 # Apache-2.0
26
oslo.middleware>=3.0.0 # Apache-2.0
27
oslo.serialization>=1.10.0 # Apache-2.0
28
oslo.utils>=3.5.0 # Apache-2.0
29 30
pysnmp<5.0.0,>=4.2.3 # BSD
python-ceilometerclient>=2.2.1 # Apache-2.0
31
python-glanceclient>=2.0.0 # Apache-2.0
32
python-keystoneclient!=1.8.0,!=2.1.0,>=1.6.0 # Apache-2.0
33
keystoneauth1>=2.1.0 # Apache-2.0
34
python-neutronclient!=4.1.0,>=2.6.0 # Apache-2.0
35 36 37 38 39 40 41
python-novaclient!=2.33.0,>=2.29.0 # Apache-2.0
python-swiftclient>=2.2.0 # Apache-2.0
PyYAML>=3.1.0 # MIT
requests!=2.9.0,>=2.8.1 # Apache-2.0
six>=1.9.0 # MIT
SQLAlchemy<1.1.0,>=1.0.10 # MIT
sqlalchemy-migrate>=0.9.6 # Apache-2.0
42
stevedore>=1.5.0 # Apache-2.0
43
tooz>=1.28.0 # Apache-2.0
44
Werkzeug>=0.7 # BSD License
45 46
WebOb>=1.2.3 # MIT
WSME>=0.8 # MIT
Julien Danjou's avatar
Julien Danjou committed
47 48
# NOTE(jd) We do not import it directly, but WSME datetime string parsing
# behaviour changes when this library is installed
49
python-dateutil>=2.4.2 # BSD