requirements.txt 1.95 KB
Newer Older
1 2 3
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
4
alembic>=0.8.10 # MIT
5
cotyledon>=1.3.0 # Apache-2.0
6
pecan!=1.0.2,!=1.0.3,!=1.0.4,!=1.2,>=1.0.0 # BSD
7
pbr!=2.1.0,>=2.0.0 # Apache-2.0
8
SQLAlchemy!=1.1.5,!=1.1.6,!=1.1.7,!=1.1.8,>=1.0.10 # MIT
9
Babel!=2.4.0,>=2.3.4 # BSD
10
futurist>=1.2.0 # Apache-2.0
11
requests>=2.14.2 # Apache-2.0
12
rfc3986>=0.3.1 # Apache-2.0
13
keystoneauth1>=3.4.0 # Apache-2.0
14
keystonemiddleware>=4.17.0 # Apache-2.0
15
python-neutronclient>=6.7.0 # Apache-2.0
16
WebOb>=1.7.1 # MIT
17
six>=1.10.0 # MIT
18
stevedore>=1.20.0 # Apache-2.0
19
oslo.config>=5.2.0 # Apache-2.0
20
oslo.context>=2.19.2 # Apache-2.0
21
oslo.db>=4.27.0 # Apache-2.0
22
oslo.i18n>=3.15.3 # Apache-2.0
23
oslo.log>=3.36.0 # Apache-2.0
24 25
oslo.messaging>=5.29.0 # Apache-2.0
oslo.middleware>=3.31.0 # Apache-2.0
26
oslo.policy>=1.30.0 # Apache-2.0
27
oslo.reports>=1.18.0 # Apache-2.0
28
oslo.serialization!=2.19.1,>=2.18.0 # Apache-2.0
29
oslo.upgradecheck>=0.1.0 # Apache-2.0
30
oslo.utils>=3.33.0 # Apache-2.0
31 32
pyasn1!=0.2.3,>=0.1.8 # BSD
pyasn1-modules>=0.0.6 # BSD
33
PyMySQL>=0.7.6 # MIT License
34
python-barbicanclient>=4.5.2 # Apache-2.0
35
python-glanceclient>=2.8.0 # Apache-2.0
36
python-novaclient>=9.1.0 # Apache-2.0
37
pyOpenSSL>=17.1.0 # Apache-2.0
38
WSME>=0.8.0 # MIT
39
Jinja2>=2.10 # BSD License (3 clause)
40
taskflow>=2.16.0 # Apache-2.0
41
diskimage-builder!=1.6.0,!=1.7.0,!=1.7.1,>=1.1.2 # Apache-2.0
42
futures>=3.0.0;python_version=='2.7' or python_version=='2.6' # BSD
43
castellan>=0.16.0 # Apache-2.0
44
tenacity>=4.9.0  # Apache-2.0
45
distro>=1.2.0 # Apache-2.0
46
jsonschema>=2.6.0 # MIT
47 48
debtcollector>=1.19.0 # Apache-2.0
octavia-lib>=1.1.1 # Apache-2.0
49 50

#for the amphora api
51
Flask!=0.11,>=0.10 # BSD
52
netifaces>=0.10.4 # MIT
53
ipaddress>=1.0.17;python_version<'3.3' # PSF
54
cryptography>=2.1 # BSD/Apache-2.0
55
pyroute2>=0.4.21;sys_platform!='win32' # Apache-2.0 (+ dual licensed GPL2)
56
gunicorn>=19.0.0 # MIT