Commit d92e7cb3 authored by Ondřej Nový's avatar Ondřej Nový

Remove prerm/preinst scripts for upgrading from version 2.6.0-2.

parent ea3affc7
......@@ -2,6 +2,7 @@ swift (2.22.0-1) UNRELEASED; urgency=medium
* New upstream release.
* Bump Standards-Version to 4.4.0.
* Remove prerm/preinst scripts for upgrading from version 2.6.0-2.
-- Ondřej Nový <onovy@debian.org> Mon, 05 Aug 2019 13:32:18 +0200
......
#!/bin/sh
set -e
if [ "$1" = "upgrade" ] ; then
# If upgrading from version older than 2.6.0-2 stop service first. In this
# version init scripts was rewritten and swift-init support was dropped
if dpkg --compare-versions "$2" lt "2.6.0-2" ; then
echo "Upgrading from < 2.6.0-2, need to stop services first"
invoke-rc.d swift-account stop || true
invoke-rc.d swift-account-auditor stop || true
invoke-rc.d swift-account-reaper stop || true
invoke-rc.d swift-account-replicator stop || true
fi
fi
#DEBHELPER#
exit 0
#!/bin/sh
set -e
if [ "$1" = "upgrade" ] ; then
# If downgrading to version older than 2.6.0-2 stop service first. In this
# version init scripts was rewritten and swift-init support was dropped
if dpkg --compare-versions "$2" lt "2.6.0-2" ; then
echo "Downgrading to < 2.6.0-2, need to stop services first"
invoke-rc.d swift-account stop || true
invoke-rc.d swift-account-auditor stop || true
invoke-rc.d swift-account-reaper stop || true
invoke-rc.d swift-account-replicator stop || true
fi
fi
#DEBHELPER#
exit 0
#!/bin/sh
set -e
if [ "$1" = "upgrade" ] ; then
# If upgrading from version older than 2.6.0-2 stop service first. In this
# version init scripts was rewritten and swift-init support was dropped
if dpkg --compare-versions "$2" lt "2.6.0-2" ; then
echo "Upgrading from < 2.6.0-2, need to stop services first"
invoke-rc.d swift-container stop || true
invoke-rc.d swift-container-auditor stop || true
invoke-rc.d swift-container-reconciler stop || true
invoke-rc.d swift-container-replicator stop || true
invoke-rc.d swift-container-sync stop || true
invoke-rc.d swift-container-updater stop || true
fi
fi
#DEBHELPER#
exit 0
#!/bin/sh
set -e
if [ "$1" = "upgrade" ] ; then
# If downgrading to version older than 2.6.0-2 stop service first. In this
# version init scripts was rewritten and swift-init support was dropped
if dpkg --compare-versions "$2" lt "2.6.0-2" ; then
echo "Downgrading to < 2.6.0-2, need to stop services first"
invoke-rc.d swift-container stop || true
invoke-rc.d swift-container-auditor stop || true
invoke-rc.d swift-container-reconciler stop || true
invoke-rc.d swift-container-replicator stop || true
invoke-rc.d swift-container-sharder stop || true
invoke-rc.d swift-container-sync stop || true
invoke-rc.d swift-container-updater stop || true
fi
fi
#DEBHELPER#
exit 0
#!/bin/sh
set -e
if [ "$1" = "upgrade" ] ; then
# If upgrading from version older than 2.6.0-2 stop service first. In this
# version init scripts was rewritten and swift-init support was dropped
if dpkg --compare-versions "$2" lt "2.6.0-2" ; then
echo "Upgrading from < 2.6.0-2, need to stop service first"
invoke-rc.d swift-object-expirer stop || true
fi
fi
#DEBHELPER#
exit 0
#!/bin/sh
set -e
if [ "$1" = "upgrade" ] ; then
# If downgrading to version older than 2.6.0-2 stop service first. In this
# version init scripts was rewritten and swift-init support was dropped
if dpkg --compare-versions "$2" lt "2.6.0-2" ; then
echo "Downgrading to < 2.6.0-2, need to stop service first"
invoke-rc.d swift-object-expirer stop || true
fi
fi
#DEBHELPER#
exit 0
#!/bin/sh
set -e
if [ "$1" = "upgrade" ] ; then
# If upgrading from version older than 2.6.0-2 stop service first. In this
# version init scripts was rewritten and swift-init support was dropped
if dpkg --compare-versions "$2" lt "2.6.0-2" ; then
echo "Upgrading from < 2.6.0-2, need to stop services first"
invoke-rc.d swift-object stop || true
invoke-rc.d swift-object-auditor stop || true
invoke-rc.d swift-object-reconstructor stop || true
invoke-rc.d swift-object-replicator stop || true
invoke-rc.d swift-object-updater stop || true
fi
fi
#DEBHELPER#
exit 0
#!/bin/sh
set -e
if [ "$1" = "upgrade" ] ; then
# If downgrading to version older than 2.6.0-2 stop service first. In this
# version init scripts was rewritten and swift-init support was dropped
if dpkg --compare-versions "$2" lt "2.6.0-2" ; then
echo "Downgrading to < 2.6.0-2, need to stop services first"
invoke-rc.d swift-object stop || true
invoke-rc.d swift-object-auditor stop || true
invoke-rc.d swift-object-reconstructor stop || true
invoke-rc.d swift-object-replicator stop || true
invoke-rc.d swift-object-updater stop || true
fi
fi
#DEBHELPER#
exit 0
#!/bin/sh
set -e
if [ "$1" = "upgrade" ] ; then
# If upgrading from version older than 2.6.0-2 stop service first. In this
# version init scripts was rewritten and swift-init support was dropped
if dpkg --compare-versions "$2" lt "2.6.0-2" ; then
echo "Upgrading from < 2.6.0-2, need to stop service first"
invoke-rc.d swift-proxy stop || true
fi
fi
#DEBHELPER#
exit 0
#!/bin/sh
set -e
if [ "$1" = "upgrade" ] ; then
# If downgrading to version older than 2.6.0-2 stop service first. In this
# version init scripts was rewritten and swift-init support was dropped
if dpkg --compare-versions "$2" lt "2.6.0-2" ; then
echo "Downgrading to < 2.6.0-2, need to stop service first"
invoke-rc.d swift-proxy stop || true
fi
fi
#DEBHELPER#
exit 0
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment