1. 22 Oct, 2018 1 commit
    • Tim Burke's avatar
      Require gettext for all non-SUSE distros · b5a91724
      Tim Burke authored
      This fixes the failing release-notes job. I guess there was some change
      to the base gate images since the related change? We've definitely
      landed other patches that would've built release notes since then...
      
      Change-Id: Iaf6296886b653f0ac3e9db52a886ea3fe4a3bd20
      Related-Change: Iff24a2b02b8927113d616a5af06331f1a1e31170
      b5a91724
  2. 15 Sep, 2018 1 commit
  3. 05 Jul, 2018 1 commit
    • Ehud Kaldor's avatar
      Add Alpine Linux suuprt to bindep · 2f4f2dd7
      Ehud Kaldor authored
      This patch adds Alpine Linux (apk) entries to bindep.txt.
      
      closes-bug: #1780163
      Change-Id: Iff24a2b02b8927113d616a5af06331f1a1e31170
      2f4f2dd7
  4. 20 Jun, 2018 1 commit
  5. 27 Apr, 2018 1 commit
    • Kota Tsuyuzaki's avatar
      Import swift3 into swift repo as s3api middleware · 636b922f
      Kota Tsuyuzaki authored
      This attempts to import openstack/swift3 package into swift upstream
      repository, namespace. This is almost simple porting except following items.
      
      1. Rename swift3 namespace to swift.common.middleware.s3api
      1.1 Rename also some conflicted class names (e.g. Request/Response)
      
      2. Port unittests to test/unit/s3api dir to be able to run on the gate.
      
      3. Port functests to test/functional/s3api and setup in-process testing
      
      4. Port docs to doc dir, then address the namespace change.
      
      5. Use get_logger() instead of global logger instance
      
      6. Avoid global conf instance
      
      Ex. fix various minor issue on those steps (e.g. packages, dependencies,
        deprecated things)
      
      The details and patch references in the work on feature/s3api are listed
      at https://trello.com/b/ZloaZ23t/s3api (completed board)
      
      Note that, because this is just a porting, no new feature is developed since
      the last swift3 release, and in the future work, Swift upstream may continue
      to work on remaining items for further improvements and the best compatibility
      of Amazon S3. Please read the new docs for your deployment and keep track to
      know what would be changed in the future releases.
      
      Change-Id: Ib803ea89cfee9a53c429606149159dd136c036fd
      Co-Authored-By: default avatarThiago da Silva <thiago@redhat.com>
      Co-Authored-By: default avatarTim Burke <tim.burke@gmail.com>
      636b922f
  6. 20 Dec, 2017 1 commit
    • Andreas Jaeger's avatar
      Install liberasurecode-devel for CentOS 7 · bdd4eb69
      Andreas Jaeger authored
      Since I747c2b8754effbc6ec82af3bf7543fd9599a6c14 we do not install
      the RDO package repository anymore and thus liberasurecode-devel
      cannot be installed.
      
      For CentOS 7, remove liberasurecode-devel from bindep.txt and install it
      from test-setup.sh instead after enabling the RDO package repositories.
      
      Update python dependencies: CentOS 7 does not have python3. Fix the
      SUSE tags.
      
      Change-Id: I72aa6b5455dfb025f54e83334983ac280f04afb2
      bdd4eb69
  7. 16 Aug, 2017 1 commit
    • Matthew Oliver's avatar
      Add OpenSuse SAIO build instructions · 0fead33b
      Matthew Oliver authored
      This patch adds OpenSuse to the build a SAIO development page.
      
      OpenSuse's libssl.so naming is different then other Linux distros
      and as such it can't simply use pip's cryptography wheel/binary,
      which by default is linked to libssl.so.10.
      To fix this, --no-binary cryptography was added to pip install:
      
        pip install --no-binary cryptography -r requirements.txt
      
      Which forces the cryptography module's binding to be compiled
      against the correct libssl.so library.
      
      Change-Id: I6a070f33d670edbb887433530c44e2cb509f0c58
      0fead33b
  8. 28 Feb, 2017 1 commit
  9. 12 Dec, 2016 1 commit
    • donagh-mccabe's avatar
      Add python3-dev to bindep and use py27for some envs · 052ca666
      donagh-mccabe authored
      Installed my workstation with Ubuntu Xenial and then hit a few
      snags running tox.
      
      python3-dev is needed to build the python3 envs. Did not actually
      test python3-devel (rpm) as I don't have such a system.
      
      While python2.7 is the default, tox (on Xenial) itself uses
      python3.5, hence 3.5 becomes the basepython and a number
      of envs don't work.
      
      Driveby, removed warning about /bin/echo in py3pep8
      
      Change-Id: Ie880246dd757570b8e444da0e643f3c50093bdc5
      052ca666
  10. 12 Aug, 2016 1 commit
  11. 01 Jul, 2016 1 commit
  12. 12 May, 2016 1 commit