Commit ba897606 authored by Thomas Goirand's avatar Thomas Goirand

Removed Python 2 support.

parent 3ac3b637
python-xstatic-spin (1.2.8.0+dfsg1-2) UNRELEASED; urgency=medium
python-xstatic-spin (1.2.8.0+dfsg1-2) unstable; urgency=medium
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
......@@ -15,6 +15,7 @@ python-xstatic-spin (1.2.8.0+dfsg1-2) UNRELEASED; urgency=medium
[ Thomas Goirand ]
* Add missing dh-python build-depends.
* Standards-Version is now 4.1.3.
* Removed Python 2 support.
-- Thomas Goirand <zigo@debian.org> Mon, 02 Apr 2018 15:49:53 +0200
......
......@@ -7,55 +7,18 @@ Uploaders:
Build-Depends:
debhelper (>= 9),
dh-python,
python-all (>= 2.6.6-3~),
python-setuptools,
openstack-pkg-tools (>= 75~),
python3-all,
python3-setuptools,
Build-Conflicts:
python-xstatic,
python3-xstatic,
Standards-Version: 4.1.3
Vcs-Browser: https://salsa.debian.org/openstack-team/xstatic/python-xstatic-spin
Vcs-Git: https://salsa.debian.org/openstack-team/xstatic/python-xstatic-spin.git
Homepage: http://fgnass.github.io/spin.js/
Package: python-xstatic-spin
Architecture: all
Pre-Depends:
dpkg (>= 1.15.6~),
Depends:
libjs-spin.js,
python-xstatic,
${misc:Depends},
${python:Depends},
Description: Spin.js XStatic support - Python 2.x
XStatic is a packaging standard to package external (often 3rd party) static
files as a Python package, so they are easily usable on all operating systems,
with any package management system or even without one.
.
Many Python projects need to use some specific data files, like javascript,
css, java applets, images, etc. Sometimes these files belong to YOUR project
(then you may want to package them separately, but you could also just put
them into your main package). But in many other cases, those files are
maintained by someone else (like jQuery javascript library or even much bigger
js libraries or applications) and you definitely do not really want to merge
them into your project. So, you want to have static file packages, but you
don’t want to get lots of stuff you do not want. Thus, stuff required by
XStatic file packages (especially the main, toplevel XStatic package) tries to
obey to be a MINIMAL, no-fat thing. XStatic doesn't "sell" any web framework
or other stuff you don't want. Maybe there will be optional XStatic extensions
for all sorts of stuff, but they won't be required if you just want the files.
.
By having static files in packages, it is also easier to build virtual envs,
support linux/bsd/... distribution package maintainers and even windows
installs using the same mechanism.
.
This package provides spin.js support as a Python 2.x module.
Package: python3-xstatic-spin
Architecture: all
Pre-Depends:
dpkg (>= 1.15.6~),
Depends:
libjs-spin.js,
python3-xstatic,
......
#!/usr/bin/make -f
PYTHONS:=$(shell pyversions -vr)
PYTHON3S:=$(shell py3versions -vr)
UPSTREAM_GIT := https://github.com/openstack/xstatic-spin.git
-include /usr/share/openstack-pkg-tools/pkgos.make
include /usr/share/openstack-pkg-tools/pkgos.make
%:
dh $@ --buildsystem=python_distutils --with python2,python3
dh $@ --buildsystem=python_distutils --with python3
override_dh_auto_clean:
echo "Do nothing..."
override_dh_install:
set -e && for pyvers in $(PYTHONS); do \
python$$pyvers setup.py install --install-layout=deb \
--root $(CURDIR)/debian/python-xstatic-spin; \
done
set -e && for pyvers in $(PYTHON3S); do \
python$$pyvers setup.py install --install-layout=deb \
--root $(CURDIR)/debian/python3-xstatic-spin; \
done
override_dh_auto_build:
echo "Do nothing..."
override_dh_auto_install:
pkgos-dh_auto_install --no-py2
rm -rf $(CURDIR)/debian/python*-xstatic-spin/usr/lib/python*/dist-packages/xstatic/pkg/spin/data
rm -rf $(CURDIR)/debian/python*-xstatic-spin/usr/lib/python*/dist-packages/*.pth
override_dh_clean:
dh_clean -O--buildsystem=python_distutils
......@@ -34,4 +29,3 @@ override_dh_installpam override_dh_installppp override_dh_installudev override_d
override_dh_installxfonts override_dh_gconf override_dh_icons override_dh_perl override_dh_usrlocal:
override_dh_installcron override_dh_installdebconf:
override_dh_installlogrotate override_dh_installgsettings:
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment