1. 30 Jan, 2010 17 commits
  2. 04 Jan, 2010 1 commit
  3. 02 Jan, 2010 1 commit
  4. 27 Dec, 2009 1 commit
  5. 23 Dec, 2009 1 commit
  6. 22 Jun, 2009 1 commit
  7. 12 Jan, 2009 1 commit
  8. 11 Aug, 2008 1 commit
  9. 08 May, 2008 1 commit
  10. 06 Mar, 2008 1 commit
  11. 28 Feb, 2008 1 commit
  12. 26 Dec, 2007 1 commit
    • Junichi Uekawa's avatar
      python-apt/gdebi based pbuilder-satisfydepends-gdebi (closes: #453388) · d4a893eb
      Junichi Uekawa authored
      From: Michael Vogt <mvo@ubuntu.com>
      
      In Ubuntu, we've applied the attached patch to achieve the following:
      
          * Makefile:
            - Addded pbuilder-satisfydepends-gdebi
          * pbuilder-buildpackage-funcs:
            - always pass --chroot to the pbuilder-satisfydepends (needed for
              pbuilder-satisfydepends-gdebi)
          * pbuilder-satisfydepends-gdebi:
            - added alternative b-d resolver
      
      pbuilder-satisfydepends-gdebi is a build-dependencies resolver based
      on gdebi (that in turn uses python-apt/libapt). It is fast and does
      not need to build a dummy package. It should behave exactly like
      apt-get build-dep $pkg
      
      It used to be more interessting because of the speed gain when
      pbuilder-satisfydepends-classic was the default. You probably want to
      add a recommends or suggests for gdebi too (if you like the patch
      method).
      
      Modified by dancerj: --chroot is given before --chrootexec so that
      cowdancer can continue to work.
      d4a893eb
  13. 14 Oct, 2007 1 commit
  14. 28 Aug, 2007 1 commit
  15. 19 Aug, 2007 1 commit
  16. 22 Jul, 2007 1 commit
  17. 23 Jun, 2007 2 commits
  18. 06 Jun, 2007 1 commit
  19. 27 May, 2007 1 commit
  20. 03 Apr, 2007 2 commits
  21. 31 Mar, 2007 1 commit
  22. 06 Nov, 2006 1 commit
    • lool's avatar
      * pbuilder-satisfydepends-experimental, Makefile: alternate · 1aa3024f
      lool authored
      implementation of pbuilder-satisfydepends which supports pulling
      build-deps with a version on the apt-get command-line; this is derived
      from pbuilder-satisfydepends with the following changes:
      - Add and use new package_versions() and candidate_version() helpers;
        the former returns all versions of a package available via APT, the
        later APT's candidate version.
      - For versionned build-deps, when building the "apt-get install"
        command, try APT's candidate version or all available versions
        available from APT in ascending order (the reverse order of
        apt-cache's output); checkbuilddep_versiondeps() isn't used for this
        part of the process anymore, but it is still used to honor
        build-conflicts.
      - Recover from APT errors caused by unsufficient dependencies
        ("libfoo-dev Depends: bar but baz is to be installed") and missing
        dependencies libfoo-dev Depends: bar but it is not going to be
        installed", or simply "libfoo-dev Depends: bar"); this permits
        simply listing build-deps when uploading to experimental; achieved
        by moving the version matching logic in the new
        versioneddep_to_aptcmd() helper.
      * pbuilderrc, pbuilderrc.5: document the availability of the alternate
      implementation.
      1aa3024f