...
 
Commits (2)
cpanminus (1.7044-2) UNRELEASED; urgency=medium
* Drop manual installation of App::cpanminus::fatscript which was used
by carton until 1.0.28.
Add a versioned Breaks on older carton versions.
-- gregor herrmann <gregoa@debian.org> Sat, 15 Dec 2018 18:27:00 +0100
cpanminus (1.7044-1) unstable; urgency=medium
[ Damyan Ivanov ]
......
......@@ -48,6 +48,7 @@ Depends: ${misc:Depends},
perl (>= 5.23.0) | libhttp-tiny-perl (>= 0.056) | curl | wget,
perl (>= 5.23.0) | libmodule-metadata-perl (>= 1.000027),
perl (>= 5.23.9) | libversion-perl (>= 1:0.9912)
Breaks: carton (<< 1.0.29)
Description: script to get, unpack, build and install modules from CPAN
cpanminus provides a command-line (non interactive) interface to
automatically download, build and install Perl modules from CPAN.
......
#!/usr/bin/make -f
BUILDHOME = $(CURDIR)/debian/build
FAT = $(CURDIR)/fatpacked/App/cpanminus/fatscript.pm
%:
dh $@
......@@ -12,8 +11,6 @@ override_dh_clean:
override_dh_auto_configure:
perl $(CURDIR)/maint/build.pl
# App::cpanminus::fatscript is used by carton, so let's install it
[ ! -f $(FAT) ] || cp -v $(FAT) $(CURDIR)/lib/App/cpanminus
dh_auto_configure
override_dh_auto_test:
......