Commit 9840ce5e authored by gregor herrmann's avatar gregor herrmann

Imported Upstream version 0.24

parent caefae6d
......@@ -6,6 +6,11 @@ TODO:
- autogenerate the grammer during ./Build
- take a look at 'use parent'
0.24 2012-02-12T14:27:36+0100
- regenerated Grammer to work with new Parse::RecDescent
(thanks to cpan-testers, TMUELLER, KENTNL and paul@city-fan.org
for reporting the problem)
0.23 2008-04-26 22:14:28
- fixed bug regarding 'use utf8' which was interpreted as 'utf'
......
......@@ -17,6 +17,6 @@ t/23_universal_require.t
t/24_version.t
t/25_utf8.t
t/80_failing.t
TODO
xt/pod.t
xt/pod_coverage.t
META.json
{
"abstract" : "Find out what modules are used",
"author" : [
"Thomas Klausner <domm@zsi.at>"
],
"dynamic_config" : 1,
"generated_by" : "Module::Build version 0.38, CPAN::Meta::Converter version 2.112150",
"license" : [
"perl_5"
],
"meta-spec" : {
"url" : "http://search.cpan.org/perldoc?CPAN::Meta::Spec",
"version" : "2"
},
"name" : "Module-ExtractUse",
"prereqs" : {
"build" : {
"requires" : {
"Test::Deep" : "0.087",
"Test::More" : 0,
"Test::NoWarnings" : 0,
"Test::Pod" : 0,
"Test::Pod::Coverage" : 0,
"UNIVERSAL::require" : 0
}
},
"configure" : {
"requires" : {
"Module::Build" : "0.38"
}
},
"runtime" : {
"requires" : {
"Parse::RecDescent" : "1.94",
"Pod::Strip" : "1.00",
"perl" : "5.008"
}
}
},
"provides" : {
"Module::ExtractUse" : {
"file" : "lib/Module/ExtractUse.pm",
"version" : "0.24"
},
"Module::ExtractUse::Grammar" : {
"file" : "lib/Module/ExtractUse/Grammar.pm",
"version" : 0
},
"Parse::RecDescent::Module::ExtractUse::Grammar" : {
"file" : "lib/Module/ExtractUse/Grammar.pm",
"version" : 0
}
},
"release_status" : "stable",
"resources" : {
"license" : [
"http://dev.perl.org/licenses/"
]
},
"version" : "0.24"
}
---
name: Module-ExtractUse
version: 0.23
abstract: 'Find out what modules are used'
author:
- 'Thomas Klausner <domm@zsi.at>'
abstract: Find out what modules are used
license: perl
resources:
license: http://dev.perl.org/licenses/
requires:
Parse::RecDescent: 1.94
Pod::Strip: 1.00
perl: 5.008
build_requires:
Test::Deep: 0.087
Test::More: 0
......@@ -18,15 +9,29 @@ build_requires:
Test::Pod: 0
Test::Pod::Coverage: 0
UNIVERSAL::require: 0
configure_requires:
Module::Build: 0.38
dynamic_config: 1
generated_by: 'Module::Build version 0.38, CPAN::Meta::Converter version 2.112150'
license: perl
meta-spec:
url: http://module-build.sourceforge.net/META-spec-v1.4.html
version: 1.4
name: Module-ExtractUse
provides:
Module::ExtractUse:
file: lib/Module/ExtractUse.pm
version: 0.23
version: 0.24
Module::ExtractUse::Grammar:
file: lib/Module/ExtractUse/Grammar.pm
version: 0
Parse::RecDescent::Module::ExtractUse::Grammar:
file: lib/Module/ExtractUse/Grammar.pm
generated_by: Module::Build version 0.280801
meta-spec:
url: http://module-build.sourceforge.net/META-spec-v1.2.html
version: 1.2
version: 0
requires:
Parse::RecDescent: 1.94
Pod::Strip: 1.00
perl: 5.008
resources:
license: http://dev.perl.org/licenses/
version: 0.24
# Note: this file was auto-generated by Module::Build::Compat version 0.2808_01
# Note: this file was auto-generated by Module::Build::Compat version 0.3800
require 5.008;
unless (eval "use Module::Build::Compat 0.02; 1" ) {
print "This module requires Module::Build to install itself.\n";
require ExtUtils::MakeMaker;
my $yn = ExtUtils::MakeMaker::prompt
(' Install Module::Build now from CPAN?', 'y');
unless ($yn =~ /^y/i) {
die " *** Cannot install without Module::Build. Exiting ...\n";
}
require Cwd;
require File::Spec;
require CPAN;
# Save this 'cause CPAN will chdir all over the place.
my $cwd = Cwd::cwd();
CPAN::Shell->install('Module::Build::Compat');
CPAN::Shell->expand("Module", "Module::Build::Compat")->uptodate
or die "Couldn't install Module::Build, giving up.\n";
chdir $cwd or die "Cannot chdir() back to $cwd: $!";
}
eval "use Module::Build::Compat 0.02; 1" or die $@;
Module::Build::Compat->run_build_pl(args => \@ARGV);
my $build_script = 'Build';
$build_script .= '.com' if $^O eq 'VMS';
exit(0) unless(-e $build_script); # cpantesters convention
require Module::Build;
Module::Build::Compat->write_makefile(build_class => 'Module::Build');
#-----------------------------------------------------------------
# TODO for Module::ExtractUse
# $Rev$
# $Date$
#-----------------------------------------------------------------
#-----------------------------------------------------------------
# for release 0.17
#-----------------------------------------------------------------
......@@ -8,7 +8,7 @@ use Pod::Strip;
use Parse::RecDescent;
use Module::ExtractUse::Grammar;
use Carp;
use version; our $VERSION=version->new('0.23');
use version; our $VERSION=version->new('0.24');
#$::RD_TRACE=1;
#$::RD_HINT=1;
......
This diff is collapsed.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment