Upgrading to GitLab 11.11.0.

Commit b039a9a6 authored by gregor herrmann's avatar gregor herrmann

New upstream version 0.342

parent e070381c
......@@ -18,7 +18,7 @@ sub process_grammar_files {
open(my $fh,'<',$grammar) || die "cannot read $grammar: $!";
my @content = <$fh>;
close $fh;
splice(@content,1,0,'our $VERSION=0.341;'."\n");
splice(@content,1,0,'our $VERSION=0.342;'."\n");
open(my $out,">",$grammar) || die "cannot write $grammer: $!";
print $out @content;
close $out;
......@@ -55,7 +55,7 @@ my %module_build_args = (
'Kenichi Ishigaki <kishigaki@gmail.com>'
],
'dist_name' => 'Module-ExtractUse',
'dist_version' => '0.341',
'dist_version' => '0.342',
'license' => 'perl',
'module_name' => 'Module::ExtractUse',
'module_name' => 'Module::ExtractUse',
......
......@@ -2,6 +2,10 @@
# Changes for Module::ExtractUse
#-----------------------------------------------------------------
0.342 2018-01-22T16:02:20
- Escape left (and right) braces to silence deprecation warnings (RT-124146) (Kenichi Ishigaki)
0.341 2016-01-30T22:18:20
- fixed 20_parse_self.t; version.pm is not used anymore (Kenichi Ishigaki)
......
This is the Perl distribution Module-ExtractUse.
Installing Module-ExtractUse is straightforward.
......@@ -9,10 +8,10 @@ If you have cpanm, you only need one line:
% cpanm Module::ExtractUse
If you are installing into a system-wide directory, you may need to pass the
"-S" flag to cpanm, which uses sudo to install the module:
% cpanm -S Module::ExtractUse
If it does not have permission to install modules to the current perl, cpanm
will automatically set up and install to a local::lib in your home directory.
See the local::lib documentation (https://metacpan.org/pod/local::lib) for
details on enabling it in your environment.
## Installing with the CPAN shell
......@@ -32,9 +31,9 @@ Then install it:
% ./Build install
If you are installing into a system-wide directory, you may need to run:
% sudo ./Build install
If your perl is system-managed, you can create a local::lib in your home
directory to install modules to. For details, see the local::lib documentation:
https://metacpan.org/pod/local::lib
## Documentation
......
# This file was automatically generated by Dist::Zilla::Plugin::Manifest v5.020.
# This file was automatically generated by Dist::Zilla::Plugin::Manifest v6.008.
Build.PL
Changes
INSTALL
......
......@@ -5,13 +5,13 @@
"Kenichi Ishigaki <kishigaki@gmail.com>"
],
"dynamic_config" : 0,
"generated_by" : "Dist::Zilla version 5.020, CPAN::Meta::Converter version 2.142060",
"generated_by" : "Dist::Zilla version 6.008, CPAN::Meta::Converter version 2.150005",
"license" : [
"perl_5"
],
"meta-spec" : {
"url" : "http://search.cpan.org/perldoc?CPAN::Meta::Spec",
"version" : "2"
"version" : 2
},
"name" : "Module-ExtractUse",
"prereqs" : {
......@@ -25,6 +25,11 @@
"Module::Build" : "0.28"
}
},
"develop" : {
"requires" : {
"Test::More" : "0"
}
},
"runtime" : {
"requires" : {
"Carp" : "0",
......@@ -52,6 +57,7 @@
"web" : "https://github.com/domm/Module-ExtractUse"
}
},
"version" : "0.341"
"version" : "0.342",
"x_serialization_backend" : "Cpanel::JSON::XS version 3.0225"
}
......@@ -11,7 +11,7 @@ build_requires:
configure_requires:
Module::Build: '0.28'
dynamic_config: 0
generated_by: 'Dist::Zilla version 5.020, CPAN::Meta::Converter version 2.142060'
generated_by: 'Dist::Zilla version 6.008, CPAN::Meta::Converter version 2.150005'
license: perl
meta-spec:
url: http://module-build.sourceforge.net/META-spec-v1.4.html
......@@ -27,4 +27,5 @@ requires:
warnings: '0'
resources:
repository: git://github.com/domm/Module-ExtractUse.git
version: '0.341'
version: '0.342'
x_serialization_backend: 'YAML::Tiny version 1.69'
This archive contains the distribution Module-ExtractUse,
version 0.341:
version 0.342:
Find out what modules are used
......@@ -11,5 +11,5 @@ This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
This README file was generated by Dist::Zilla::Plugin::Readme v5.020.
This README file was generated by Dist::Zilla::Plugin::Readme v6.008.
......@@ -8,7 +8,7 @@ use Pod::Strip;
use Parse::RecDescent 1.967009;
use Module::ExtractUse::Grammar;
use Carp;
our $VERSION = '0.341';
our $VERSION = '0.342';
# ABSTRACT: Find out what modules are used
......@@ -32,13 +32,13 @@ sub new {
my $re_block;
$re_block = qr {
( # eval BLOCK, corresponding to the group 10 in the entire regex
{
\{
((?:
(?> [^{}]+ ) # Non-braces without backtracking
|
(??{$re_block}) # Recurse to group 10
)*)
}
\}
)
}xs;
my $re = qr{
......@@ -63,13 +63,13 @@ my $re = qr{
(?:(['"])(.*?)\8) # eval '' or eval "", group 8, group 9
|
( # eval BLOCK, group 10
{
\{
((?: # group 11
(?> [^{}]+ ) # Non-braces without backtracking
|
(??{$re_block}) # Recurse to group 10
)*)
}
\}
)
))
)
......@@ -349,7 +349,7 @@ Module::ExtractUse - Find out what modules are used
=head1 VERSION
version 0.341
version 0.342
=head1 SYNOPSIS
......
......@@ -12217,7 +12217,7 @@ Module::ExtractUse::Grammar
=head1 VERSION
version 0.341
version 0.342
=head1 AUTHORS
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment