Commit a40562c8 authored by gregor herrmann's avatar gregor herrmann

Imported Upstream version 0.33

parent 69fe2eab
Revision history for Package-Stash
0.33 2011-09-28
- add conflict on MooseX::Method::Signatures 0.36 (ether)
0.32 2011-09-05
- bring the behavior of has_symbol for nonexistant scalars into line with
the xs version
......
......@@ -4,7 +4,7 @@
"Jesse Luehrs <doy at tozt dot net>"
],
"dynamic_config" : "1",
"generated_by" : "Dist::Zilla version 4.200012, CPAN::Meta::Converter version 2.110440",
"generated_by" : "Dist::Zilla version 4.300002, CPAN::Meta::Converter version 2.110440",
"license" : [
"perl_5"
],
......@@ -52,7 +52,7 @@
"web" : "http://github.com/doy/package-stash"
}
},
"version" : "0.32",
"version" : "0.33",
"x_Dist_Zilla" : {
"plugins" : [
{
......@@ -64,52 +64,52 @@
}
},
"name" : "@DOY/TestMoreDoneTesting",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::GatherDir",
"name" : "@DOY/GatherDir",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::PruneCruft",
"name" : "@DOY/PruneCruft",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::ManifestSkip",
"name" : "@DOY/ManifestSkip",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::MetaYAML",
"name" : "@DOY/MetaYAML",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::License",
"name" : "@DOY/License",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::Readme",
"name" : "@DOY/Readme",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::ExtraTests",
"name" : "@DOY/ExtraTests",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::ExecDir",
"name" : "@DOY/ExecDir",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::ShareDir",
"name" : "@DOY/ShareDir",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "inc::MMPackageStash",
......@@ -119,32 +119,32 @@
{
"class" : "Dist::Zilla::Plugin::Manifest",
"name" : "@DOY/Manifest",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::TestRelease",
"name" : "@DOY/TestRelease",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::ConfirmRelease",
"name" : "@DOY/ConfirmRelease",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::MetaConfig",
"name" : "@DOY/MetaConfig",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::MetaJSON",
"name" : "@DOY/MetaJSON",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::NextRelease",
"name" : "@DOY/NextRelease",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::CheckChangesHasContent",
......@@ -154,17 +154,17 @@
{
"class" : "Dist::Zilla::Plugin::PkgVersion",
"name" : "@DOY/PkgVersion",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::PodCoverageTests",
"name" : "@DOY/PodCoverageTests",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::PodSyntaxTests",
"name" : "@DOY/PodSyntaxTests",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::NoTabsTests",
......@@ -209,7 +209,7 @@
{
"class" : "Dist::Zilla::Plugin::UploadToCPAN",
"name" : "@DOY/UploadToCPAN",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "inc::DistMeta",
......@@ -225,7 +225,7 @@
}
},
"name" : "Prereqs",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::Prereqs",
......@@ -236,7 +236,7 @@
}
},
"name" : "RuntimeRecommends",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::Prereqs",
......@@ -247,7 +247,7 @@
}
},
"name" : "TestRequires",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::Prereqs",
......@@ -258,7 +258,7 @@
}
},
"name" : "DevelopRequires",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::Conflicts",
......@@ -268,32 +268,32 @@
{
"class" : "Dist::Zilla::Plugin::FinderCode",
"name" : ":InstallModules",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::FinderCode",
"name" : ":IncModules",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::FinderCode",
"name" : ":TestFiles",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::FinderCode",
"name" : ":ExecFiles",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::FinderCode",
"name" : ":ShareFiles",
"version" : "4.200012"
"version" : "4.300002"
},
{
"class" : "Dist::Zilla::Plugin::FinderCode",
"name" : ":MainModule",
"version" : "4.200012"
"version" : "4.300002"
}
],
"zilla" : {
......@@ -301,11 +301,12 @@
"config" : {
"is_trial" : "0"
},
"version" : "4.200012"
"version" : "4.300002"
}
},
"x_conflicts" : {
"Class::MOP" : "1.08",
"MooseX::Method::Signatures" : "0.36",
"MooseX::Role::WithOverloading" : "0.08",
"namespace::clean" : "0.18"
}
......
......@@ -10,7 +10,7 @@ configure_requires:
Dist::CheckConflicts: 0.02
ExtUtils::MakeMaker: 6.30
dynamic_config: 1
generated_by: 'Dist::Zilla version 4.200012, CPAN::Meta::Converter version 2.110440'
generated_by: 'Dist::Zilla version 4.300002, CPAN::Meta::Converter version 2.110440'
license: perl
meta-spec:
url: http://module-build.sourceforge.net/META-spec-v1.4.html
......@@ -25,7 +25,7 @@ requires:
perl: 5.8.1
resources:
repository: git://github.com/doy/package-stash.git
version: 0.32
version: 0.33
x_Dist_Zilla:
plugins:
-
......@@ -35,43 +35,43 @@ x_Dist_Zilla:
phase: test
type: requires
name: '@DOY/TestMoreDoneTesting'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::GatherDir
name: '@DOY/GatherDir'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::PruneCruft
name: '@DOY/PruneCruft'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::ManifestSkip
name: '@DOY/ManifestSkip'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::MetaYAML
name: '@DOY/MetaYAML'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::License
name: '@DOY/License'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::Readme
name: '@DOY/Readme'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::ExtraTests
name: '@DOY/ExtraTests'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::ExecDir
name: '@DOY/ExecDir'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::ShareDir
name: '@DOY/ShareDir'
version: 4.200012
version: 4.300002
-
class: inc::MMPackageStash
name: '@DOY/=inc::MMPackageStash'
......@@ -79,27 +79,27 @@ x_Dist_Zilla:
-
class: Dist::Zilla::Plugin::Manifest
name: '@DOY/Manifest'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::TestRelease
name: '@DOY/TestRelease'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::ConfirmRelease
name: '@DOY/ConfirmRelease'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::MetaConfig
name: '@DOY/MetaConfig'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::MetaJSON
name: '@DOY/MetaJSON'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::NextRelease
name: '@DOY/NextRelease'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::CheckChangesHasContent
name: '@DOY/CheckChangesHasContent'
......@@ -107,15 +107,15 @@ x_Dist_Zilla:
-
class: Dist::Zilla::Plugin::PkgVersion
name: '@DOY/PkgVersion'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::PodCoverageTests
name: '@DOY/PodCoverageTests'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::PodSyntaxTests
name: '@DOY/PodSyntaxTests'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::NoTabsTests
name: '@DOY/NoTabsTests'
......@@ -151,7 +151,7 @@ x_Dist_Zilla:
-
class: Dist::Zilla::Plugin::UploadToCPAN
name: '@DOY/UploadToCPAN'
version: 4.200012
version: 4.300002
-
class: inc::DistMeta
name: '=inc::DistMeta'
......@@ -163,7 +163,7 @@ x_Dist_Zilla:
phase: runtime
type: requires
name: Prereqs
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::Prereqs
config:
......@@ -171,7 +171,7 @@ x_Dist_Zilla:
phase: runtime
type: recommends
name: RuntimeRecommends
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::Prereqs
config:
......@@ -179,7 +179,7 @@ x_Dist_Zilla:
phase: test
type: requires
name: TestRequires
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::Prereqs
config:
......@@ -187,7 +187,7 @@ x_Dist_Zilla:
phase: develop
type: requires
name: DevelopRequires
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::Conflicts
name: Conflicts
......@@ -195,33 +195,34 @@ x_Dist_Zilla:
-
class: Dist::Zilla::Plugin::FinderCode
name: ':InstallModules'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::FinderCode
name: ':IncModules'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::FinderCode
name: ':TestFiles'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::FinderCode
name: ':ExecFiles'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::FinderCode
name: ':ShareFiles'
version: 4.200012
version: 4.300002
-
class: Dist::Zilla::Plugin::FinderCode
name: ':MainModule'
version: 4.200012
version: 4.300002
zilla:
class: Dist::Zilla::Dist::Builder
config:
is_trial: 0
version: 4.200012
version: 4.300002
x_conflicts:
Class::MOP: 1.08
MooseX::Method::Signatures: 0.36
MooseX::Role::WithOverloading: 0.08
namespace::clean: 0.18
......@@ -29,7 +29,7 @@ my %WriteMakefileArgs = (
'Package::DeprecationManager' => '0',
'Scalar::Util' => '0'
},
'VERSION' => '0.32',
'VERSION' => '0.33',
'test' => {
'TESTS' => 't/*.t t/impl-selection/*.t'
}
......
This archive contains the distribution Package-Stash,
version 0.32:
version 0.33:
routines for manipulating stashes
......
......@@ -33,3 +33,4 @@ Test::LeakTrace = 0
Class::MOP = 1.08
MooseX::Role::WithOverloading = 0.08
namespace::clean = 0.18
MooseX::Method::Signatures = 0.36
package Package::Stash;
BEGIN {
$Package::Stash::VERSION = '0.32';
{
$Package::Stash::VERSION = '0.33';
}
use strict;
use warnings;
......@@ -102,7 +102,7 @@ Package::Stash - routines for manipulating stashes
=head1 VERSION
version 0.32
version 0.33
=head1 SYNOPSIS
......
......@@ -8,6 +8,7 @@ use Dist::CheckConflicts
-dist => 'Package::Stash',
-conflicts => {
'Class::MOP' => '1.08',
'MooseX::Method::Signatures' => '0.36',
'MooseX::Role::WithOverloading' => '0.08',
'namespace::clean' => '0.18',
},
......
package Package::Stash::PP;
BEGIN {
$Package::Stash::PP::VERSION = '0.32';
{
$Package::Stash::PP::VERSION = '0.33';
}
use strict;
use warnings;
......@@ -374,7 +374,7 @@ Package::Stash::PP - pure perl implementation of the Package::Stash API
=head1 VERSION
version 0.32
version 0.33
=head1 SYNOPSIS
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment