Skip to content
Snippets Groups Projects
Commit c814c859 authored by Bas Couwenberg's avatar Bas Couwenberg
Browse files

Add patch to fix FTBFS due to pod sections embedded in pp_addxs commands. (closes: #952305)

parent db00ec00
No related branches found
No related tags found
No related merge requests found
......@@ -4,6 +4,8 @@ libpdl-io-matlab-perl (0.005-4) UNRELEASED; urgency=medium
* Bump Standards-Version to 4.5.0, no changes.
* Update watch file to use releases instead of tags.
* Update gbp.conf to use --source-only-changes by default.
* Add patch to fix FTBFS due to pod sections embedded in pp_addxs commands.
(closes: #952305)
[ gregor herrmann ]
* debian/control: update Build-Depends for cross builds.
......
Description: Fix FTBFS due to pod sections embedded in pp_addxs commands.
Author: Bas Couwenberg <sebastic@debian.org>
Bug-Debian: https://bugs.debian.org/952305
--- a/matlab.pd
+++ b/matlab.pd
@@ -869,38 +869,12 @@ if (RETVAL == -1) barf("PDL::IO::Matlab:
OUTPUT:
RETVAL
-=pod
-
-int
-_my_mat_feof(mat)
-mat_t * mat
-CODE:
-RETVAL = feof(mat->fp);
-OUTPUT:
-RETVAL
-
-=cut
-
-
');
pp_addxs ( '', '
-=pod
-
-void
-_extra_matio_print_all_var_info_new (matfp,printdata,max_cols,max_rows)
-mat_t * matfp
-int printdata
-int max_cols
-int max_rows
-CODE:
-extra_matio_print_all_var_info (matfp,printdata,max_cols,max_rows);
-
-=cut
-
void
_extra_matio_print_all_var_info (matfp,printdata)
mat_t * matfp
@@ -908,17 +882,6 @@ int printdata
CODE:
extra_matio_print_all_var_info(matfp,printdata);
-=pod
-
-following was a PITA. This returns undef if the
-reading matvar failed. The library does not seem
-to provide any way to detect EOF.
-
-Important not to use fprintf in this XS code. Can
-cause segfault.
-
-=cut
-
void
_convert_next_matvar_to_pdl(matfp,onedr)
mat_t * matfp
@@ -938,22 +901,6 @@ XPUSHs(p);
XPUSHs(s);
-=pod
-
-old method
-pdl *
-disa_convert_next_matvar_to_pdl(matfp)
-mat_t * matfp
-CODE:
-pdl * retval;
-matvar_t * matvar;
-retval = convert_next_matvar_to_pdl(matfp, &matvar);
-Mat_VarFree(matvar);
-ST(0) = sv_newmortal();
-if (retval != NULL) PDL->SetSV_PDL(ST(0),retval);
-
-=cut
-
int
_write_pdl_to_matlab_file (mat, piddle, varname, oned, compress)
mat_t * mat
......@@ -3,3 +3,4 @@
0003-printf-format-types-now-use-z-when-printing-size_t-d.patch
0004-Make-now-knows-about-a-source-dependency-and-can-reb.patch
0005-removed-POD-coverage-tests.-these-fail.-I-notified-u.patch
pod.patch
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment