Commit 2796ec90 authored by gregor herrmann's avatar gregor herrmann

Imported Upstream version 1.000000

parent 21b331da
.build
Test-File-ShareDir-*
language: perl
matrix:
allow_failures:
- perl: "5.8"
- env: STERILIZE_ENV=0 RELEASE_TESTING=1 AUTHOR_TESTING=1
- env: STERILIZE_ENV=0 DEVELOPER_DEPS=1
include:
- perl: "5.8"
env: STERILIZE_ENV=0
......@@ -19,6 +23,12 @@ matrix:
env: STERILIZE_ENV=1
- perl: "5.10"
env: STERILIZE_ENV=1
- perl: "5.12"
env: STERILIZE_ENV=1
- perl: "5.14"
env: STERILIZE_ENV=1
- perl: "5.18"
env: STERILIZE_ENV=1
- perl: "5.19"
env: STERILIZE_ENV=1
- perl: "5.19"
......@@ -27,8 +37,10 @@ matrix:
env: STERILIZE_ENV=0 RELEASE_TESTING=1 AUTHOR_TESTING=1
before_install:
- perlbrew list
- time perl ./maint-travis-ci/branch_reset.pl
- time perl ./maint-travis-ci/sterilize_env.pl
install:
- time perl ./maint-travis-ci/install_deps_early.pl
- time perl ./maint-travis-ci/install_deps.pl
before_script:
- time perl ./maint-travis-ci/before_script.pl
......
use strict;
use warnings;
use Module::Build 0.3601;
my %module_build_args = (
"build_requires" => {
"Module::Build" => "0.4202"
},
"configure_requires" => {
"Module::Build" => "0.4202"
},
"dist_abstract" => "Create a Fake ShareDir for your modules for testing.",
"dist_author" => [
"Kent Fredric <kentnl\@cpan.org>"
],
"dist_name" => "Test-File-ShareDir",
"dist_version" => "0.4.1",
"license" => "perl",
"module_name" => "Test::File::ShareDir",
"recommends" => {},
"recursive_test_files" => 1,
"requires" => {
"Carp" => 0,
"Class::Tiny" => 0,
"File::Copy::Recursive" => 0,
"File::ShareDir" => "1.00",
"File::Temp" => 0,
"Path::Tiny" => 0,
"perl" => "5.006",
"strict" => 0,
"warnings" => 0
},
"script_files" => [],
"test_requires" => {
"Cwd" => 0,
"FindBin" => 0,
"Test::Fatal" => 0,
"Test::More" => "1.001002",
"lib" => 0
}
);
my %fallback_build_requires = (
"Cwd" => 0,
"FindBin" => 0,
"Module::Build" => "0.4202",
"Test::Fatal" => 0,
"Test::More" => "1.001002",
"lib" => 0
);
unless ( eval { Module::Build->VERSION(0.4004) } ) {
delete $module_build_args{test_requires};
$module_build_args{build_requires} = \%fallback_build_requires;
}
my $build = Module::Build->new(%module_build_args);
$build->create_build_script;
Release history for Test-File-ShareDir
1.000000 2014-01-30T15:23:48Z
[00 Tooling and Version replacement]
- Switched to EUMM to accelerate clean-install time.
- Build-time requirements are now softened
- Readvertise higher requirements as recommendations
- version schema moved from x.y.z to x.YYYzzz and is the primary reason
for incrementing the major
[Dependencies::Stats]
- Dependencies changed since 0.4.1, see Changes.deps{,.all,.dev} for
details
- build: -1
- configure: +2 -1
- develop: +7 ↑1 -9
- test: +8 ↓1
0.4.1 2013-11-21T06:51:24Z
[00 Trivial Doc Fix]
- Escaping of code containing > was done wrong.
......@@ -9,82 +25,18 @@ Release history for Test-File-ShareDir
- New Modules/Interfaces to make life easier for people who only need one
of (Dist|Module) shares.
[Dependencies::Added / develop requires]
- Dist::Zilla::Plugin::Author::KENTNL::MinimumPerl
- Dist::Zilla::Plugin::Authority 1.006
- Dist::Zilla::Plugin::AutoPrereqs
- Dist::Zilla::Plugin::CheckExtraTests
- Dist::Zilla::Plugin::ConfirmRelease
- Dist::Zilla::Plugin::EOLTests
- Dist::Zilla::Plugin::Git::Check
- Dist::Zilla::Plugin::Git::Commit
- Dist::Zilla::Plugin::Git::CommitBuild
- Dist::Zilla::Plugin::Git::GatherDir
- Dist::Zilla::Plugin::Git::NextVersion
- Dist::Zilla::Plugin::Git::Tag
- Dist::Zilla::Plugin::GithubMeta
- Dist::Zilla::Plugin::License
- Dist::Zilla::Plugin::Manifest
- Dist::Zilla::Plugin::ManifestSkip
- Dist::Zilla::Plugin::MetaConfig
- Dist::Zilla::Plugin::MetaData::BuiltWith
- Dist::Zilla::Plugin::MetaJSON
- Dist::Zilla::Plugin::MetaProvides::Package 1.14000001
- Dist::Zilla::Plugin::MetaTests
- Dist::Zilla::Plugin::MetaYAML
- Dist::Zilla::Plugin::ModuleBuild
- Dist::Zilla::Plugin::NextRelease
- Dist::Zilla::Plugin::PkgVersion
- Dist::Zilla::Plugin::PodCoverageTests
- Dist::Zilla::Plugin::PodSyntaxTests
- Dist::Zilla::Plugin::PodWeaver
- Dist::Zilla::Plugin::Prereqs
- Dist::Zilla::Plugin::Prereqs::MatchInstalled
- Dist::Zilla::Plugin::PruneCruft
- Dist::Zilla::Plugin::ReadmeAnyFromPod
- Dist::Zilla::Plugin::ReadmeFromPod
- Dist::Zilla::Plugin::ReportVersions::Tiny
- Dist::Zilla::Plugin::Test::CPAN::Changes
- Dist::Zilla::Plugin::Test::Compile::PerFile
- Dist::Zilla::Plugin::Test::Kwalitee
- Dist::Zilla::Plugin::Test::MinimumVersion
- Dist::Zilla::Plugin::Test::Perl::Critic
- Dist::Zilla::Plugin::TestRelease
- Dist::Zilla::Plugin::Twitter
- Dist::Zilla::Plugin::UploadToCPAN
- Dist::Zilla::PluginBundle::Author::KENTNL 2.002001
- Test::CPAN::Changes 0.19
- Test::Kwalitee 1.12
[Dependencies::Added / develop suggests]
- Dist::Zilla::PluginBundle::Author::KENTNL::Lite v1.3.0
[Dependencies::Added / runtime requires]
- Class::Tiny
[Dependencies::Added / test requires]
- lib
[Dependencies::Changed / build requires]
- Module::Build 0.4004 → 0.4202
[Dependencies::Changed / configure requires]
- Module::Build 0.4004 → 0.4202
[Dependencies::Changed / test requires]
- Test::More 0.98 → 1.001002
[Dependencies::Removed / develop recommends]
- Dist::Zilla::PluginBundle::Author::KENTNL::Lite v1.3.0
[Dependencies::Removed / develop requires]
- Dist::Zilla::PluginBundle::Author::KENTNL::Lite
[Dependencies::Removed / develop suggests]
- Dist::Zilla::PluginBundle::Author::KENTNL v1.7.2
[Dependencies::Removed / test requires]
- File::Find
[Dependencies::Noteworthy]
- use Class::Tiny
- use new MB and TestMore
[Dependencies::Stats]
- Dependencies changed since 0.3.3, see Changes.deps{,.all,.dev} for
details
- build: ↑1
- configure: ↑1
- develop: +46 -3
- runtime: +1
- test: +1 ↑1 -1
[Documentation]
- Encoding specified
......@@ -103,39 +55,30 @@ Release history for Test-File-ShareDir
[!Noteable Changes]
- Replace Path::Class with Path::Tiny
[Dependencies::Added / runtime_requires]
- Path::Tiny
[Dependencies::Noteworthy]
- use Path::Tiny
- stop using Path::Class::Dir
[Dependencies::Removed / runtime_requires]
- Path::Class::Dir
[Dependencies::Stats]
- Dependencies changed since 0.3.2, see Changes.deps{,.all,.dev} for
details
- runtime: +1 -1
0.3.2 2013-04-03T07:03:58Z
- Maintenance release for MB 0.4004
[Dependencies::Added / develop_requires]
- Pod::Coverage::TrustPod
- Test::CPAN::Meta
- Test::Pod 1.41
- Test::Pod::Coverage 1.08
- version 0.9901
[Dependencies::Added / runtime_requires]
- perl 5.006
[Dependencies::Changed / build_requires]
- Module::Build 0.3601 → 0.4004
[Dependencies::Changed / configure_requires]
- Module::Build 0.3601 → 0.4004
[Dependencies::Noteworthy]
- 5.006 is now minimum
- upgrade MB and TM
[Dependencies::Changed / develop_recommends]
- Dist::Zilla::PluginBundle::Author::KENTNL::Lite 0.01009803 → v1.3.0
[Dependencies::Changed / develop_suggests]
- Dist::Zilla::PluginBundle::Author::KENTNL 1.0.0 → v1.7.2
[Dependencies::Changed / test_requires]
- Test::More 0.96 → 0.98
[Dependencies::Stats]
- Dependencies changed since 0.3.1, see Changes.deps{,.all,.dev} for
details
- build: ↑1
- configure: ↑1
- develop: +5 ↑2
- runtime: +1
- test: ↑1
[Documentation]
- Reindent License
......@@ -158,16 +101,27 @@ Release history for Test-File-ShareDir
Path::Class properly which should fix this problem. Thanks to RJBS for
diagnosing and reporting this problem.
[Dependencies]
[Dependencies::Noteworthy]
- test removed: English
[Dependencies::Stats]
- Dependencies changed since 0.3.0, see Changes.deps{,.all,.dev} for
details
- runtime: +2
- test: -1
[Packaging]
- Updated License ( Indentation, Address )
- Extra tests moved to xt/
0.3.0 2011-05-05T03:29:45Z
[Dependencies::Testing]
- Now requires Cwd as provided by File-Spec / PathTools.
[Dependencies::Noteworthy]
- For testing, Now requires Cwd as provided by File-Spec / PathTools.
[Dependencies::Stats]
- Dependencies changed since 0.2.0, see Changes.deps{,.all,.dev} for
details
- test: +1
[Documentation]
- Improved primary documentation to explain import flags
......@@ -207,6 +161,11 @@ Release history for Test-File-ShareDir
- Slightly more strict, but just to stop you doing stupid things.
- Module Loading is now slightly lazier.
[Dependencies::Stats]
- Dependencies changed since 0.1.0, see Changes.deps{,.all,.dev} for
details
- runtime: +1 -1
0.1.0 2011-02-21T12:42:47Z
- First version, released on an unsuspecting world.
- Presently only supports module share-dirs.
......
1.000000
[Added / configure recommends]
- ExtUtils::MakeMaker 6.86
[Added / configure requires]
- ExtUtils::MakeMaker 6.30
[Added / test recommends]
- CPAN::Meta
- CPAN::Meta::Requirements 2.120900
- ExtUtils::MakeMaker 6.86
- Test::More 1.001002
[Added / test requires]
- ExtUtils::MakeMaker
- File::Spec::Functions
- List::Util
- version
[Changed / test requires]
- Test::More 1.001002 → 0.96
[Removed / build requires]
- Module::Build 0.4202
[Removed / configure requires]
- Module::Build 0.4202
0.4.1 2013-11-21T06:51:24Z
0.4.0 2013-11-21T06:38:44Z
[Added / runtime requires]
- Class::Tiny
[Added / test requires]
- lib
[Changed / build requires]
- Module::Build 0.4004 → 0.4202
[Changed / configure requires]
- Module::Build 0.4004 → 0.4202
[Changed / test requires]
- Test::More 0.98 → 1.001002
[Removed / test requires]
- File::Find
0.3.3 2013-04-03T11:32:08Z
[Added / runtime requires]
- Path::Tiny
[Removed / runtime requires]
- Path::Class::Dir
0.3.2 2013-04-03T07:03:58Z
[Added / runtime requires]
- perl 5.006
[Changed / build requires]
- Module::Build 0.3601 → 0.4004
[Changed / configure requires]
- Module::Build 0.3601 → 0.4004
[Changed / test requires]
- Test::More 0.96 → 0.98
0.3.1 2011-10-28T20:58:28Z
[Added / runtime requires]
- strict
- warnings
[Removed / test requires]
- English
0.3.0 2011-05-05T03:29:45Z
[Added / test requires]
- Cwd
0.2.0 2011-04-07T21:10:54Z
0.1.2 2011-04-07T21:08:05Z
0.1.1 2011-03-10T16:35:13Z
[Added / runtime requires]
- Path::Class::Dir
[Removed / runtime requires]
- Path::Class
1.000000
[Added / configure recommends]
- ExtUtils::MakeMaker 6.86
[Added / configure requires]
- ExtUtils::MakeMaker 6.30
[Added / develop requires]
- Dist::Zilla::Plugin::Git::NextRelease
- Dist::Zilla::Plugin::Git::NextVersion::Sanitized
- Dist::Zilla::Plugin::MakeMaker
- Dist::Zilla::Plugin::MinimumPerl
- Dist::Zilla::Plugin::Prereqs::Recommend::MatchInstalled
- Dist::Zilla::Plugin::RunExtraTests
- Dist::Zilla::Plugin::Test::ReportPrereqs
[Added / test recommends]
- CPAN::Meta
- CPAN::Meta::Requirements 2.120900
- ExtUtils::MakeMaker 6.86
- Test::More 1.001002
[Added / test requires]
- ExtUtils::MakeMaker
- File::Spec::Functions
- List::Util
- version
[Changed / develop requires]
- Dist::Zilla::PluginBundle::Author::KENTNL 2.002001 → 2.011001
[Changed / test requires]
- Test::More 1.001002 → 0.96
[Removed / build requires]
- Module::Build 0.4202
[Removed / configure requires]
- Module::Build 0.4202
[Removed / develop requires]
- Dist::Zilla::Plugin::Author::KENTNL::MinimumPerl
- Dist::Zilla::Plugin::CheckExtraTests
- Dist::Zilla::Plugin::Git::NextVersion
- Dist::Zilla::Plugin::ModuleBuild
- Dist::Zilla::Plugin::NextRelease
- Dist::Zilla::Plugin::Prereqs::MatchInstalled
- Dist::Zilla::Plugin::PruneCruft
- Dist::Zilla::Plugin::ReportVersions::Tiny
- version 0.9901
0.4.1 2013-11-21T06:51:24Z
0.4.0 2013-11-21T06:38:44Z
[Added / develop requires]
- Dist::Zilla::Plugin::Author::KENTNL::MinimumPerl
- Dist::Zilla::Plugin::Authority 1.006
- Dist::Zilla::Plugin::AutoPrereqs
- Dist::Zilla::Plugin::CheckExtraTests
- Dist::Zilla::Plugin::ConfirmRelease
- Dist::Zilla::Plugin::EOLTests
- Dist::Zilla::Plugin::Git::Check
- Dist::Zilla::Plugin::Git::Commit
- Dist::Zilla::Plugin::Git::CommitBuild
- Dist::Zilla::Plugin::Git::GatherDir
- Dist::Zilla::Plugin::Git::NextVersion
- Dist::Zilla::Plugin::Git::Tag
- Dist::Zilla::Plugin::GithubMeta
- Dist::Zilla::Plugin::License
- Dist::Zilla::Plugin::Manifest
- Dist::Zilla::Plugin::ManifestSkip
- Dist::Zilla::Plugin::MetaConfig
- Dist::Zilla::Plugin::MetaData::BuiltWith
- Dist::Zilla::Plugin::MetaJSON
- Dist::Zilla::Plugin::MetaProvides::Package 1.14000001
- Dist::Zilla::Plugin::MetaTests
- Dist::Zilla::Plugin::MetaYAML
- Dist::Zilla::Plugin::ModuleBuild
- Dist::Zilla::Plugin::NextRelease
- Dist::Zilla::Plugin::PkgVersion
- Dist::Zilla::Plugin::PodCoverageTests
- Dist::Zilla::Plugin::PodSyntaxTests
- Dist::Zilla::Plugin::PodWeaver
- Dist::Zilla::Plugin::Prereqs
- Dist::Zilla::Plugin::Prereqs::MatchInstalled
- Dist::Zilla::Plugin::PruneCruft
- Dist::Zilla::Plugin::ReadmeAnyFromPod
- Dist::Zilla::Plugin::ReadmeFromPod
- Dist::Zilla::Plugin::ReportVersions::Tiny
- Dist::Zilla::Plugin::Test::CPAN::Changes
- Dist::Zilla::Plugin::Test::Compile::PerFile
- Dist::Zilla::Plugin::Test::Kwalitee
- Dist::Zilla::Plugin::Test::MinimumVersion
- Dist::Zilla::Plugin::Test::Perl::Critic
- Dist::Zilla::Plugin::TestRelease
- Dist::Zilla::Plugin::Twitter
- Dist::Zilla::Plugin::UploadToCPAN
- Dist::Zilla::PluginBundle::Author::KENTNL 2.002001
- Test::CPAN::Changes 0.19
- Test::Kwalitee 1.12
[Added / develop suggests]
- Dist::Zilla::PluginBundle::Author::KENTNL::Lite v1.3.0
[Added / runtime requires]
- Class::Tiny
[Added / test requires]
- lib
[Changed / build requires]
- Module::Build 0.4004 → 0.4202
[Changed / configure requires]
- Module::Build 0.4004 → 0.4202
[Changed / test requires]
- Test::More 0.98 → 1.001002
[Removed / develop recommends]
- Dist::Zilla::PluginBundle::Author::KENTNL::Lite v1.3.0
[Removed / develop requires]
- Dist::Zilla::PluginBundle::Author::KENTNL::Lite
[Removed / develop suggests]
- Dist::Zilla::PluginBundle::Author::KENTNL v1.7.2
[Removed / test requires]
- File::Find
0.3.3 2013-04-03T11:32:08Z
[Added / runtime requires]
- Path::Tiny
[Removed / runtime requires]
- Path::Class::Dir
0.3.2 2013-04-03T07:03:58Z
[Added / develop requires]
- Pod::Coverage::TrustPod
- Test::CPAN::Meta
- Test::Pod 1.41
- Test::Pod::Coverage 1.08
- version 0.9901
[Added / runtime requires]
- perl 5.006
[Changed / build requires]
- Module::Build 0.3601 → 0.4004
[Changed / configure requires]
- Module::Build 0.3601 → 0.4004
[Changed / develop recommends]
- Dist::Zilla::PluginBundle::Author::KENTNL::Lite 0.01009803 → v1.3.0
[Changed / develop suggests]
- Dist::Zilla::PluginBundle::Author::KENTNL v1.0.0 → v1.7.2
[Changed / test requires]
- Test::More 0.96 → 0.98
0.3.1 2011-10-28T20:58:28Z
[Added / runtime requires]
- strict
- warnings
[Removed / test requires]
- English
0.3.0 2011-05-05T03:29:45Z
[Added / test requires]
- Cwd
0.2.0 2011-04-07T21:10:54Z
0.1.2 2011-04-07T21:08:05Z
0.1.1 2011-03-10T16:35:13Z
[Added / runtime requires]
- Path::Class::Dir
[Removed / runtime requires]
- Path::Class
1.000000
[Added / develop requires]
- Dist::Zilla::Plugin::Git::NextRelease
- Dist::Zilla::Plugin::Git::NextVersion::Sanitized
- Dist::Zilla::Plugin::MakeMaker
- Dist::Zilla::Plugin::MinimumPerl
- Dist::Zilla::Plugin::Prereqs::Recommend::MatchInstalled
- Dist::Zilla::Plugin::RunExtraTests
- Dist::Zilla::Plugin::Test::ReportPrereqs
[Changed / develop requires]
- Dist::Zilla::PluginBundle::Author::KENTNL 2.002001 → 2.011001
[Removed / develop requires]
- Dist::Zilla::Plugin::Author::KENTNL::MinimumPerl
- Dist::Zilla::Plugin::CheckExtraTests
- Dist::Zilla::Plugin::Git::NextVersion
- Dist::Zilla::Plugin::ModuleBuild
- Dist::Zilla::Plugin::NextRelease
- Dist::Zilla::Plugin::Prereqs::MatchInstalled
- Dist::Zilla::Plugin::PruneCruft
- Dist::Zilla::Plugin::ReportVersions::Tiny
- version 0.9901
0.4.1 2013-11-21T06:51:24Z
0.4.0 2013-11-21T06:38:44Z
[Added / develop requires]
- Dist::Zilla::Plugin::Author::KENTNL::MinimumPerl
- Dist::Zilla::Plugin::Authority 1.006
- Dist::Zilla::Plugin::AutoPrereqs
- Dist::Zilla::Plugin::CheckExtraTests
- Dist::Zilla::Plugin::ConfirmRelease
- Dist::Zilla::Plugin::EOLTests
- Dist::Zilla::Plugin::Git::Check
- Dist::Zilla::Plugin::Git::Commit
- Dist::Zilla::Plugin::Git::CommitBuild
- Dist::Zilla::Plugin::Git::GatherDir
- Dist::Zilla::Plugin::Git::NextVersion
- Dist::Zilla::Plugin::Git::Tag
- Dist::Zilla::Plugin::GithubMeta
- Dist::Zilla::Plugin::License
- Dist::Zilla::Plugin::Manifest
- Dist::Zilla::Plugin::ManifestSkip
- Dist::Zilla::Plugin::MetaConfig
- Dist::Zilla::Plugin::MetaData::BuiltWith
- Dist::Zilla::Plugin::MetaJSON
- Dist::Zilla::Plugin::MetaProvides::Package 1.14000001
- Dist::Zilla::Plugin::MetaTests
- Dist::Zilla::Plugin::MetaYAML
- Dist::Zilla::Plugin::ModuleBuild
- Dist::Zilla::Plugin::NextRelease
- Dist::Zilla::Plugin::PkgVersion
- Dist::Zilla::Plugin::PodCoverageTests
- Dist::Zilla::Plugin::PodSyntaxTests
- Dist::Zilla::Plugin::PodWeaver
- Dist::Zilla::Plugin::Prereqs
- Dist::Zilla::Plugin::Prereqs::MatchInstalled
- Dist::Zilla::Plugin::PruneCruft
- Dist::Zilla::Plugin::ReadmeAnyFromPod
- Dist::Zilla::Plugin::ReadmeFromPod
- Dist::Zilla::Plugin::ReportVersions::Tiny
- Dist::Zilla::Plugin::Test::CPAN::Changes
- Dist::Zilla::Plugin::Test::Compile::PerFile
- Dist::Zilla::Plugin::Test::Kwalitee
- Dist::Zilla::Plugin::Test::MinimumVersion
- Dist::Zilla::Plugin::Test::Perl::Critic
- Dist::Zilla::Plugin::TestRelease
- Dist::Zilla::Plugin::Twitter
- Dist::Zilla::Plugin::UploadToCPAN
- Dist::Zilla::PluginBundle::Author::KENTNL 2.002001
- Test::CPAN::Changes 0.19
- Test::Kwalitee 1.12
[Added / develop suggests]
- Dist::Zilla::PluginBundle::Author::KENTNL::Lite v1.3.0
[Removed / develop recommends]
- Dist::Zilla::PluginBundle::Author::KENTNL::Lite v1.3.0
[Removed / develop requires]
- Dist::Zilla::PluginBundle::Author::KENTNL::Lite
[Removed / develop suggests]
- Dist::Zilla::PluginBundle::Author::KENTNL v1.7.2
0.3.3 2013-04-03T11:32:08Z
0.3.2 2013-04-03T07:03:58Z
[Added / develop requires]
- Pod::Coverage::TrustPod
- Test::CPAN::Meta
- Test::Pod 1.41
- Test::Pod::Coverage 1.08
- version 0.9901
[Changed / develop recommends]
- Dist::Zilla::PluginBundle::Author::KENTNL::Lite 0.01009803 → v1.3.0
[Changed / develop suggests]
- Dist::Zilla::PluginBundle::Author::KENTNL v1.0.0 → v1.7.2
0.3.1 2011-10-28T20:58:28Z
0.3.0 2011-05-05T03:29:45Z
0.2.0 2011-04-07T21:10:54Z
0.1.2 2011-04-07T21:08:05Z
0.1.1 2011-03-10T16:35:13Z
This software is copyright (c) 2013 by Kent Fredric <kentnl@cpan.org>.
This software is copyright (c) 2014 by Kent Fredric <kentnl@cpan.org>.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
......@@ -12,7 +12,7 @@ b) the "Artistic License"
--- The GNU General Public License, Version 1, February 1989 ---
This software is Copyright (c) 2013 by Kent Fredric <kentnl@cpan.org>.
This software is Copyright (c) 2014 by Kent Fredric <kentnl@cpan.org>.
This is free software, licensed under:
......@@ -272,7 +272,7 @@ That's all there is to it!
--- The Artistic License 1.0 ---
This software is Copyright (c) 2013 by Kent Fredric <kentnl@cpan.org>.
This software is Copyright (c) 2014 by Kent Fredric <kentnl@cpan.org>.
This is free software, licensed under:
......
# This file was automatically generated by Dist::Zilla::Plugin::Manifest v5.012.
.gitignore
.perltidyrc
.travis.yml
Build.PL
Changes
Changes.deps
Changes.deps.all
Changes.deps.dev
LICENSE
MANIFEST
META.json
META.yml
Makefile.PL
README
dist.ini
layout/self_structure.dot
......@@ -19,13 +24,17 @@ lib/Test/File/ShareDir/Object/Module.pm
lib/Test/File/ShareDir/TempDirObject.pm
maint-travis-ci/README.mkdn
maint-travis-ci/before_script.pl
maint-travis-ci/branch_reset.pl
maint-travis-ci/create_github_repo.pl
maint-travis-ci/install_deps.pl
maint-travis-ci/install_deps_early.pl
maint-travis-ci/lib/tools.pm
maint-travis-ci/merge_travis_yml.pl
maint-travis-ci/report_fail_ctx.pl
maint-travis-ci/script.pl
maint-travis-ci/sterilize_env.pl
maint-travis-ci/sync_tree.pl
maint-travis-ci/travis_enable.pl
maint-travis-ci/yamls/sterile.mkdn
maint-travis-ci/yamls/sterile.yaml
maint-travis-ci/yamls/sterile2.yaml
......@@ -37,7 +46,7 @@ t/00-compile/lib_Test_File_ShareDir_Object_Inc_pm.t
t/00-compile/lib_Test_File_ShareDir_Object_Module_pm.t
t/00-compile/lib_Test_File_ShareDir_TempDirObject_pm.t
t/00-compile/lib_Test_File_ShareDir_pm.t
t/000-report-versions-tiny.t
t/00-report-prereqs.t
t/01_basic.t
t/01_files/lib/Example.pm
t/01_files/share/afile
......
This diff is collapsed.
This diff is collapsed.
# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v5.012.
use strict;