Commit 86bca38e authored by Axel Beckert's avatar Axel Beckert

Fix patchedit to support $EDITOR to contain commandline options

Example: EDITOR="emacsclient -a emacs"
parent 3a3c5697
......@@ -309,7 +309,7 @@ sub edit_patch {
my $patch = shift;
my $editor = $ENV{'EDITOR'} || $ENV{'VISUAL'} || '/usr/bin/editor';
system( $editor, $patch );
system( "$editor $patch" );
}
sub _read_patch {
......
pkg-perl-tools (0.23) UNRELEASED; urgency=medium
* Fix patchedit to not expect a file in $PATH as $EDITOR but to support
$EDITOR to contain commandline options.
-- Axel Beckert <abe@debian.org> Mon, 10 Aug 2015 14:25:39 +0200
pkg-perl-tools (0.22) unstable; urgency=medium
[ gregor herrmann ]
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment