Commit 0a1ab5ec authored by Ramūnas Dronga's avatar Ramūnas Dronga

set minimum PHP version to 5.6

parent d03f83b8
......@@ -2,8 +2,6 @@ language: php
matrix:
include:
- php: 5.4
- php: 5.5
- php: 5.6
- php: 7.0
- php: 7.1
......
......@@ -10,8 +10,6 @@
This library is a _pure PHP_ implementation of the [AMQP 0-9-1 protocol](http://www.rabbitmq.com/tutorials/amqp-concepts.html).
It's been tested against [RabbitMQ](http://www.rabbitmq.com/).
**Requirements: PHP 5.3** due to the use of `namespaces`.
**Requirements: bcmath extension** This library utilizes the bcmath PHP extension. The installation steps vary per PHP version and the underlying OS. The following example shows how to add to an existing PHP installation on Ubuntu 15.10:
```bash
......
......@@ -29,13 +29,13 @@
}
],
"require": {
"php": ">=5.4.0",
"php": ">=5.6",
"ext-bcmath": "*",
"ext-sockets": "*"
},
"require-dev": {
"ext-curl": "*",
"phpunit/phpunit": "^4.8",
"phpunit/phpunit": "^4.8|^5.7",
"squizlabs/php_codesniffer": "^2.5",
"phpdocumentor/phpdocumentor": "^2.9",
"nategood/httpful": "^0.2.20"
......@@ -54,7 +54,7 @@
"license": "LGPL-2.1-or-later",
"extra": {
"branch-alias": {
"dev-master": "2.8-dev"
"dev-master": "2.10-dev"
}
}
}
FROM php:5.4-cli
FROM php:5.6-cli
RUN apt update && \
apt -qy install git unzip zlib1g-dev && \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment