diff --git a/debian/changelog b/debian/changelog
index 12108cf7288f4191a95f52ea7a76536fc2736c70..f952aa69b2a8b242b7a062fcf740c2d470720822 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+phpldapadmin (1.2.6.7-3) UNRELEASED; urgency=medium
+
+  * Fix PHP 8.4 error: Creation of dynamic property AttributeType
+    (Closes: #1100771)
+
+ -- William Desportes <williamdes@wdes.fr>  Mon, 24 Mar 2025 16:04:06 +0100
+
 phpldapadmin (1.2.6.7-2) unstable; urgency=medium
   * Add a patch for PHP 8.4 E_DEPRECATED
   * Add a patch to stop using xml_set_object for PHP 8.4 (Closes: #1089729)
diff --git a/debian/patches/Fix-dynamic-property-PHP-8.2.patch b/debian/patches/Fix-dynamic-property-PHP-8.2.patch
index 698e51016ae446fc0940eaa6a8745d3cdb968b34..306d8236aca6d198df90e039fb15221fb4f7250e 100644
--- a/debian/patches/Fix-dynamic-property-PHP-8.2.patch
+++ b/debian/patches/Fix-dynamic-property-PHP-8.2.patch
@@ -13,6 +13,7 @@ Subject: Fix Creation of dynamic property
 
 Origin: vendor
 Forwarded: https://github.com/leenooks/phpLDAPadmin/pull/202
+Bug-Debian: https://bugs.debian.org/1100771
 ---
  lib/PLAAttribute.php     | 1 +
  lib/Query.php            | 1 +
@@ -20,7 +21,8 @@ Forwarded: https://github.com/leenooks/phpLDAPadmin/pull/202
  lib/TemplateRender.php   | 2 ++
  lib/import_functions.php | 1 +
  lib/page.php             | 1 +
- 6 files changed, 7 insertions(+)
+ lib/schema_functions.php | 2 +-
+ 7 files changed, 8 insertions(+), 1 deletion(-)
 
 diff --git a/lib/PLAAttribute.php b/lib/PLAAttribute.php
 index a2f0091..dfcc8e6 100644
@@ -95,3 +97,16 @@ index 43efc2a..e8241a9 100644
  class page {
  	# pre-HTML headers
  	protected $_pageheader;
+diff --git a/lib/schema_functions.php b/lib/schema_functions.php
+index 6218064..70c6e8b 100644
+--- a/lib/schema_functions.php
++++ b/lib/schema_functions.php
+@@ -24,7 +24,7 @@ abstract class SchemaItem {
+ 	# The description of this schema item.
+ 	protected $description = '';
+ 	# Boolean value indicating whether this objectClass is obsolete
+-	private $is_obsolete = false;
++	protected $is_obsolete = false;
+ 
+ 	public function setOID($oid) {
+ 		if (DEBUG_ENABLED && (($fargs=func_get_args())||$fargs='NOARGS'))