Commit 8f71574d authored by Adam Conrad's avatar Adam Conrad Committed by Mark A. Hershberger

Imported Debian patch 5.0.4-2

parent 51cd902a
php5 (5.0.4-2) unstable; urgency=low
* We now have a mailing list. Set the maintainer to the list, and move
myself to Uploaders where, apparently, I belong.
* Use ZEND_MODULE_API_NO rather than PHP_API_VERSION for extension deps,
as recent upstream ABI breakage in 4.4.0 leads me to believe this is
the only constant they actually bother to update on ABI changes.
* Bring back some concflicts that went missing (libapache-mod-php5 needs
to conflict with libapache-mod-php4 and older versions of php4, while
the two libapache2-mod-php[45] modules also need to conflict).
* Adjust debian/watch to not match on upstream's alpha/beta/rc releases.
-- Adam Conrad <adconrad@0c3.net> Wed, 27 Jul 2005 22:30:42 +1000
php5 (5.0.4-1) unstable; urgency=low
* Initial PHP5 release; packaging forked from php4 4:4.3.11-1.
......
Source: php5
Section: web
Priority: optional
Maintainer: Adam Conrad <adconrad@0c3.net>
Uploaders: Steve Langasek <vorlon@debian.org>, Andres Salomon <dilinger@debian.org>, Jeroen van Wolffelaar <jeroen@wolffelaar.nl>, Ondřej Surý <ondrej@debian.org>
Maintainer: Debian PHP Maintainers <pkg-php-maint@lists.alioth.debian.org>
Uploaders: Adam Conrad <adconrad@0c3.net>, Steve Langasek <vorlon@debian.org>, Andres Salomon <dilinger@debian.org>, Jeroen van Wolffelaar <jeroen@wolffelaar.nl>, Ondřej Surý <ondrej@debian.org>
Build-Depends: apache-dev (>= 1.3.23), apache2-prefork-dev (>= 2.0.53-3), autoconf, automake1.4, bison, chrpath, debhelper (>= 3), dpkg-dev (>= 1.13.9), flex (>= 2.5.4), freetds-dev, po-debconf, libbz2-dev (>= 1.0.0), libcurl3-dev, libdb4.2-dev, libexpat1-dev (>= 1.95.2-2.1), libfreetype6-dev, libgcrypt11-dev, libgd2-xpm-dev (>= 2.0.28-3), libjpeg62-dev, libkrb5-dev, libldap2-dev, libmhash-dev (>= 0.8.8), libmysqlclient12-dev, libncurses5-dev, libpam0g-dev, libpcre3-dev (>= 4.3-1), libpng12-dev, libpq-dev, librecode-dev, libsnmp5-dev, libsqlite0-dev, libssl-dev (>= 0.9.6), libt1-dev, libtool (>= 1.4.2-4), libwrap0-dev, libxmltok1-dev, libxml2-dev (>= 2.4.14), libxslt1-dev (>= 1.0.18), re2c, unixodbc-dev, zlib1g-dev (>= 1.0.9)
Build-Conflicts: bind-dev
Standards-Version: 3.6.2
......@@ -40,7 +40,7 @@ Description: Common files for packages built from the php5 source
Package: libapache-mod-php5
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, mime-support (>= 2.03-1), ${apache:Depends}, php5-common (= ${Source-Version}), libmagic1
Conflicts: php3
Conflicts: php3, php4 (<< 4:4.3.8-6), libapache-mod-php4
Provides: ${php:Provides}
Suggests: php-pear
Description: server-side, HTML-embedded scripting language (apache 1.3 module)
......@@ -63,6 +63,7 @@ Description: server-side, HTML-embedded scripting language (apache 1.3 module)
Package: libapache2-mod-php5
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, mime-support (>= 2.03-1), ${apache2:Depends}, php5-common (= ${Source-Version}), libmagic1
Conflicts: libapache2-mod-php4
Provides: ${php:Provides}
Suggests: php-pear
Description: server-side, HTML-embedded scripting language (apache 2.0 module)
......
......@@ -78,8 +78,8 @@ COMMON_CONFIG= --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) \
apachever=$(shell dpkg -s apache-dev | grep ^Version | cut -d\ -f2 | cut -d- -f1)
php5ver=$(shell head -1 debian/changelog | cut -d\ -f 2 | sed 's/[()]//g')
zendapiver=$(shell egrep '\#define ZEND_MODULE_API_NO ' ./Zend/zend_modules.h|sed 's/\#define ZEND_MODULE_API_NO //')
phpapiver=$(shell grep '\#define PHP_API_VERSION ' ./main/php.h|sed -e 's/\#define PHP_API_VERSION //')
zendapiver=$(shell egrep '\#define ZEND_MODULE_API_NO ' ./Zend/zend_modules.h|awk '{print $$3}')
phpapiver=$(shell grep '\#define PHP_API_VERSION ' ./main/php.h|awk '{print $$3}')
patch: patch-stamp
patch-stamp:
......@@ -453,13 +453,13 @@ binary-arch: build install
# dh_perl
dh_shlibdeps -a
echo "apache:Depends=apache-common (>= $(apachever))" >>debian/libapache-mod-php5.substvars
echo "php:Provides=phpapi-$(phpapiver)" >> debian/libapache-mod-php5.substvars
echo "php:Provides=phpapi-$(phpapiver)" >> debian/php5-cli.substvars
echo "php:Provides=phpapi-$(phpapiver)" >> debian/php5-cgi.substvars
echo "php:Provides=phpapi-$(phpapiver)" >> debian/libapache2-mod-php5.substvars
echo "php:Provides=phpapi-$(zendapiver)" >> debian/libapache-mod-php5.substvars
echo "php:Provides=phpapi-$(zendapiver)" >> debian/php5-cli.substvars
echo "php:Provides=phpapi-$(zendapiver)" >> debian/php5-cgi.substvars
echo "php:Provides=phpapi-$(zendapiver)" >> debian/libapache2-mod-php5.substvars
cat debian/modulelist | while read package extname dsoname; do \
echo "php:Depends=phpapi-$(phpapiver)" >> debian/php5-$$package.substvars; \
echo "php:Depends=phpapi-$(zendapiver)" >> debian/php5-$$package.substvars; \
done
echo "apache2:Depends=apache2-mpm-prefork (>> 2.0.52)" >>debian/libapache2-mod-php5.substvars
......
version=2
http://www.php.net/downloads.php /get/php-(5\..*)\.tar\.gz/from/a/mirror
http://www.php.net/downloads.php /get/php-(5\.[0-9\.]*)\.tar\.gz/from/a/mirror
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment