Commit ddab5850 authored by Adam Conrad's avatar Adam Conrad Committed by Mark A. Hershberger

Imported Debian patch 5.0.5-3

parent 1c08414e
php5 (5.0.5-3) unstable; urgency=low
* Build-Depend on libcurl3-openssl-dev, since libcurl3-dev is going away
soon. Keep libcurl3-dev as an alternate for backporting (see: #334367)
* Switch from libmysqlclient12 to libmysqlclient14; this puts us on the
*other* side of the line regarding which combinations of DSOs cause
segfaults, so hopefully the others catch up with us soon (closes: #332453)
* Look for magic.mime in /usr/share/file now instead of /usr/share/misc/file,
as the path has been changed to comply with the FHS (see: #334510)
* Make the above backportable as well, by searching for both files, and
picking the one that's currently installed on the user's system.
* Include swedish debconf translation from Daniel Nylander (closes: #330763)
* Make pear use '/usr/bin/php' instead of just 'php' to make sure we don't
get some random binary on $PATH that won't work right (closes: #329415)
* Set PHP_PEAR_SIG_BIN to /usr/bin/gpg, and have php-pear Recommends: gnupg
-- Adam Conrad <adconrad@ubuntu.com> Fri, 21 Oct 2005 02:30:19 +1000
php5 (5.0.5-2) unstable; urgency=medium
* Remove Andres Salomon from the Uploaders field, at his request. Thanks
......
......@@ -3,7 +3,7 @@ Section: web
Priority: optional
Maintainer: Debian PHP Maintainers <pkg-php-maint@lists.alioth.debian.org>
Uploaders: Adam Conrad <adconrad@0c3.net>, Steve Langasek <vorlon@debian.org>, Jeroen van Wolffelaar <jeroen@wolffelaar.nl>, Ondřej Surý <ondrej@debian.org>
Build-Depends: apache-dev (>= 1.3.23), apache2-prefork-dev (>= 2.0.53-3), autoconf, automake1.4, bison, chrpath, debhelper (>= 3), flex (>= 2.5.4), freetds-dev, po-debconf, libbz2-dev (>= 1.0.0), libcurl3-dev, libdb4.2-dev, libexpat1-dev (>= 1.95.2-2.1), libfreetype6-dev, libgcrypt11-dev, libgd2-xpm-dev (>= 2.0.28-3), libgdbm-dev, libjpeg62-dev, libkrb5-dev, libldap2-dev, libmhash-dev (>= 0.8.8), libmysqlclient12-dev, libncurses5-dev, libpam0g-dev, libpcre3-dev (>= 4.3-1), libpng12-dev, libpq-dev | postgresql-dev, librecode-dev, libsnmp9-dev | libsnmp-dev, libsqlite0-dev, libssl-dev (>= 0.9.6), libt1-dev, libtool (>= 1.4.2-4), libwrap0-dev, libxmltok1-dev, libxml2-dev (>= 2.4.14), libxslt1-dev (>= 1.0.18), re2c, unixodbc-dev, zlib1g-dev (>= 1.0.9)
Build-Depends: apache-dev (>= 1.3.23), apache2-prefork-dev (>= 2.0.53-3), autoconf, automake1.4, bison, chrpath, debhelper (>= 3), flex (>= 2.5.4), freetds-dev, po-debconf, libbz2-dev (>= 1.0.0), libcurl3-openssl-dev | libcurl3-dev, libdb4.2-dev, libexpat1-dev (>= 1.95.2-2.1), libfreetype6-dev, libgcrypt11-dev, libgd2-xpm-dev (>= 2.0.28-3), libgdbm-dev, libjpeg62-dev, libkrb5-dev, libldap2-dev, libmhash-dev (>= 0.8.8), libmysqlclient14-dev, libncurses5-dev, libpam0g-dev, libpcre3-dev (>= 4.3-1), libpng12-dev, libpq-dev | postgresql-dev, librecode-dev, libsnmp9-dev | libsnmp-dev, libsqlite0-dev, libssl-dev (>= 0.9.6), libt1-dev, libtool (>= 1.4.2-4), libwrap0-dev, libxmltok1-dev, libxml2-dev (>= 2.4.14), libxslt1-dev (>= 1.0.18), re2c, unixodbc-dev, zlib1g-dev (>= 1.0.9)
Build-Conflicts: bind-dev
Standards-Version: 3.6.2
......@@ -147,6 +147,7 @@ Description: Files for PHP5 module development
Package: php-pear
Architecture: all
Depends: php5-cli | php4-cli, php5-common (>= ${Source-Version})
Recommends: gnupg
Replaces: php4-pear (<< 4:4.4.0-0), php-html-template-it
Provides: php-html-template-it
Conflicts: php-html-template-it
......
# Translators, if you are not familiar with the PO format, gettext
# documentation is worth reading, especially sections dedicated to
# this format, e.g. by running:
# info -n '(gettext)PO Files'
# info -n '(gettext)Header Entry'
# Some information specific to po-debconf are available at
# /usr/share/doc/po-debconf/README-trans
# or http://www.debian.org/intl/l10n/po-debconf/README-trans
# Developers do not need to manually edit POT or PO files.
# , fuzzy
#
#
msgid ""
msgstr ""
"Project-Id-Version: php5 5.0.5-1\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2005-07-16 23:18+1000\n"
"PO-Revision-Date: 2005-09-29 19:01-0700\n"
"Last-Translator: Daniel Nylander <po@danielnylander.se>\n"
"Language-Team: Swedish <sv@li.org>\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=iso-8859-1\n"
"Content-Transfer-Encoding: 8bit\n"
#. Type: boolean
#. Description
#: ../php5-module.templates:4
msgid "Should ${extname} be added to /etc/php5/${sapiconfig}/php.ini?"
msgstr "Ska ${extname} lggas till i /etc/php5/${sapiconfig}/php.ini?"
#. Type: boolean
#. Description
#: ../php5-module.templates:4
msgid ""
"You are installing ${extname} support for php5, and it is not yet enabled in "
"the configuration for the ${sapiconfig} SAPI. Do you want this extension to "
"be enabled now?"
msgstr ""
"Du installerar ${extname} std fr php5 och den r nnu inte aktiverad i "
"konfigurationen fr ${sapiconfig} SAPI. Vill du aktivera den nu?"
#. Type: boolean
#. Description
#: ../php5-module.templates:12
msgid "Should ${extname} be removed from /etc/php5/${sapiconfig}/php.ini?"
msgstr "Ska ${extname} raderas frn /etc/php5/${sapiconfig}/php.ini?"
#. Type: boolean
#. Description
#: ../php5-module.templates:12
msgid ""
"You are removing ${extname} support for php5, but it is still enabled in the "
"configuration for the ${sapiconfig} SAPI. Leaving this in place will "
"probably cause problems when trying to use PHP."
msgstr ""
"Du tar bort ${extname} stdet fr php5 och den r fortfarande aktiverad i "
"konfigurationen fr ${sapiconfig} SAPI. Lmna den aktiverad kan skapa "
"problem nr du anvnder PHP."
......@@ -42,6 +42,15 @@ else
CFLAGS += -gstabs
endif
# Old magic.mime location:
ifeq ($(wildcard /usr/share/misc/file/magic.mime), /usr/share/misc/file/magic.mime)
MAGIC_MIME = /usr/share/misc/file/magic.mime
endif
# New magic.mime location:
ifeq ($(wildcard /usr/share/file/magic.mime), /usr/share/file/magic.mime)
MAGIC_MIME = /usr/share/file/magic.mime
endif
COMMON_CONFIG= --build=$(PHP5_BUILD_GNU_TYPE)-gnu --host=$(PHP5_HOST_GNU_TYPE)-gnu \
--mandir=/usr/share/man \
--enable-memory-limit \
......@@ -80,7 +89,7 @@ COMMON_CONFIG= --build=$(PHP5_BUILD_GNU_TYPE)-gnu --host=$(PHP5_HOST_GNU_TYPE)-
--with-openssl=/usr \
--enable-dbx \
--enable-soap \
--with-mime-magic=/usr/share/misc/file/magic.mime \
--with-mime-magic=$(MAGIC_MIME) \
--with-exec-dir=/usr/lib/php5/libexec
patch: patch-stamp
......@@ -310,7 +319,7 @@ install: build
main/config.{nw,w32}.h \
main/win95nt.h
# install PEAR
cd cgi-build && make install-pear PHP_PEAR_PHP_BIN=php PHP_PEAR_INSTALL_DIR=/usr/share/php PHP_PEAR_SYSCONF_DIR=/etc/pear INSTALL_ROOT=$(CURDIR)/debian/php-pear
cd cgi-build && make install-pear PHP_PEAR_PHP_BIN=/usr/bin/php PHP_PEAR_INSTALL_DIR=/usr/share/php PHP_PEAR_SYSCONF_DIR=/etc/pear PHP_PEAR_SIG_BIN=/usr/bin/gpg INSTALL_ROOT=$(CURDIR)/debian/php-pear
# install extensions
ext=`./debian/libapache2-mod-php5/usr/bin/php-config --extension-dir`;\
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment