Commit 17ba2998 authored by Sylvestre Ledru's avatar Sylvestre Ledru

- Fix the scan-build warning (Closes: #725332)

* clang-modernize-3.4 was not coinstallable with clang 3.4
  (Closes: #724245)
* The package wasn't cleaned correctly (Closes: #722155)
* libtinfo-dev is now a dependency of llvm-3.4-dev (Closes: #727129)
* Disable the build of lldb under HURD
* Ship the lldb headers into lldb-X.Y-dev (Closes: #723743)
  I might create a liblldb-X.Y library at some point but I think it is too
  early.
* Update the build dependency from tcl8.5 to tcl (Closes: #725953)
parent f111124c
llvm-toolchain-snapshot (1:3.4~svn193603-1) unstable; urgency=low
* New snapshot release
- Fix the scan-build warning (Closes: #725332)
* Merge changes from the 3.3 branch (see 1:3.3-11)
* Add lldb-3.4-dev package
* Remove mipsel-ftbfs.diff (applied upstream)
......@@ -8,11 +9,20 @@ llvm-toolchain-snapshot (1:3.4~svn193603-1) unstable; urgency=low
* libprofile_rt and runtime has been removed upstream (r191835)
Features are provided by compiler-rt
* Update the build dependency from tcl8.5 to tcl (Closes: #725954)
* clang-modernize-3.4 was not coinstallable with clang 3.4
(Closes: #724245)
* The package wasn't cleaned correctly (Closes: #722155)
* libtinfo-dev is now a dependency of llvm-3.4-dev (Closes: #727129)
* Install libclang.so in /usr/lib/*/libclang-3.4.so
* Install libclang.so.1 in /usr/lib/*/libclang-3.3.so.1
* Also ship the python clang binding (python-clang-3.4)
* Enable polly if the dependencies are OK
* Honor the option "nocheck"
* Disable the build of lldb under HURD
* Ship the lldb headers into lldb-X.Y-dev (Closes: #723743)
I might create a liblldb-X.Y library at some point but I think it is too
early.
* Update the build dependency from tcl8.5 to tcl (Closes: #725953)
-- Sylvestre Ledru <sylvestre@debian.org> Fri, 20 Sep 2013 05:25:17 +0200
......@@ -27,17 +37,6 @@ llvm-toolchain-snapshot (1:3.4~svn190846-1) unstable; urgency=low
* Directory www/ from tarballs polly & lldb removed
* Update of the description of LLVM packages
(LLVM no longer mean Low Level Virtual Machine)
* Disable the build of lldb under HURD
* Ship the lldb headers into lldb-X.Y-dev (Closes: #723743)
I might create a liblldb-X.Y library at some point but I think it is too
early.
* Fix "cannot compile this atomic library call"
Thanks to Francisco Facioni for the refresh (Closes: #705115)
* Install libclang.so in /usr/lib/*/libclang-3.3.so
* Install libclang.so.1 in /usr/lib/*/libclang-3.3.so.1
* Also ship the python clang binding (python-clang-3.3)
* Fix a FTBFS with a duplicate declaration of shouldUseInlineAtomic
* Update the build dependency from tcl8.5 to tcl (Closes: #725953)
[ Luca Falavigna ]
* debian/control:
......
......@@ -349,7 +349,8 @@ Description: Modular compiler and toolchain technologies, IR interpreter
Package: llvm-3.4-dev
Architecture: any
Depends: ${shlibs:Depends}, libffi-dev (>= 3.0.9), ${misc:Depends}, llvm-3.4 (= ${binary:Version})
Depends: ${shlibs:Depends}, libffi-dev (>= 3.0.9), ${misc:Depends},
llvm-3.4 (= ${binary:Version}), libtinfo-dev
Replaces: llvm (<< 2.2-3)
Description: Modular compiler and toolchain technologies, libraries and headers
LLVM is a collection of libraries and tools that make it easy to build
......
......@@ -362,5 +362,4 @@ override_dh_auto_clean:
find test -name '*.pyc' -o -name '*.cm[ix]' | xargs -r rm -f
find test/Bindings -name '*.o' | xargs -r rm -f
rm -f tools/clang tools/polly tools/lldb projects/compiler-rt
rm -rf tools/clang/tools/extra
rm -rf tools/clang/tools/extra clang/tools/extra/
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment