Commit 82ef1354 authored by Sylvestre Ledru's avatar Sylvestre Ledru

* remove dep from lld to llvm-7-dev because lld

  doesn't use LLVM LTO
* remove old Replaces/Breaks
parent 3609b7b6
......@@ -3,7 +3,9 @@ llvm-toolchain-7 (1:7-3) unstable; urgency=medium
* Fix a syntax issue in a scan-build patch
* Fix the autopkgtest script (no gcc in the test)
* Create a new llvm-lto-7-dev package to ship lto
This will avoid to download llvm-dev to get lld
* remove dep from lld to llvm-7-dev because lld
doesn't use LLVM LTO
* remove old Replaces/Breaks
-- Sylvestre Ledru <sylvestre@debian.org> Fri, 21 Sep 2018 22:48:47 +0200
......
......@@ -255,8 +255,6 @@ Description: Modular compiler and toolchain technologies
Package: llvm-7-runtime
Architecture: any
Depends: binfmt-support, ${shlibs:Depends}, ${misc:Depends}
Conflicts: llvm (<< 2.7-1)
Replaces: llvm (<< 2.7-1)
Description: Modular compiler and toolchain technologies, IR interpreter
LLVM is a collection of libraries and tools that make it easy to build
compilers, optimizers, just-in-time code generators, and many other
......@@ -278,7 +276,6 @@ Architecture: any
Depends: ${shlibs:Depends}, libffi-dev (>= 3.0.9), ${misc:Depends},
llvm-7 (= ${binary:Version}), libllvm7 (= ${binary:Version}), libtinfo-dev,
libllvm-lto-7-dev
Replaces: llvm (<< 2.2-3)
Description: Modular compiler and toolchain technologies, libraries and headers
LLVM is a collection of libraries and tools that make it easy to build
compilers, optimizers, just-in-time code generators, and many other
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment