Commit c5d94812 authored by Reshabh Sharma's avatar Reshabh Sharma Committed by Sylvestre Ledru

Removed libc++-helpers package

parent 5ae3a93d
......@@ -15,6 +15,7 @@ llvm-toolchain-7 (1:7~+rc2-1~exp3) experimental; urgency=medium
[ Reshabh Sharma ]
* Added version for libc++ and OpenMP packages breaks/replaces
* Removed libc++-helpers package
-- Sylvestre Ledru <sylvestre@debian.org> Sun, 26 Aug 2018 14:00:14 +0200
......
#!/bin/sh
clang++-@LLVM_VERSION@ -stdlib=libc++ "$@"
......@@ -547,7 +547,7 @@ Package: libc++-7-dev
Section: libdevel
Architecture: any
Multi-Arch: same
Depends: libc++1-7 (= ${binary:Version}), ${misc:Depends}, libc++-7-helpers (= ${source:Version})
Depends: libc++1-7 (= ${binary:Version}), ${misc:Depends}
Provides: libstdc++-dev, libc++-dev
Breaks: libc++-dev (<< 7~+rc1-1~exp1)
Replaces: libc++-dev (<< 7~+rc1-1~exp1)
......@@ -600,25 +600,3 @@ Description: LLVM low level support for a standard C++ library (development file
.
* Correctness as defined by the C++ standards.
* Provide a portable sublayer to ease the porting of libc++
Package: libc++-7-helpers
Architecture: all
Multi-Arch: foreign
Depends: ${misc:Depends}
Breaks: libc++-helpers (<< 7~+rc1-1~exp1)
Provides: libc++-helpers
Replaces: libc++-helpers (<< 7~+rc1-1~exp1)
Description: LLVM C++ Standard library - build helpers
libc++ is another implementation of the C++ standard library
.
Features and Goals
.
* Correctness as defined by the C++ standards.
* Fast execution.
* Minimal memory use.
* Fast compile times.
* ABI compatibility with gcc's libstdc++ for some low-level features such
as exception objects, rtti and memory allocation.
* Extensive unit tests.
.
This package contains the build helpers (clang++-libc++, etc)
#!/bin/sh
cxx_libs="-lc++"
c_libs="-lc -lgcc_s"
pthread_libs="-lpthread $c_libs"
libs="$cxx_libs $c_libs"
for i; do
if test x"$i" = x"-pthread"; then
libs="$libs $pthread_libs"
break
fi
done
gcc -std=c++0x -nodefaultlibs $libs -isystem/usr/lib/llvm-@LLVM_VERSION@/include/c++/v1/ "$@"
debian/clang++-libc++ usr/lib/llvm-@LLVM_VERSION@/bin/
debian/g++-libc++ usr/lib/llvm-@LLVM_VERSION@/bin/
usr/lib/llvm-@LLVM_VERSION@/bin/clang++-libc++ usr/bin/clang++-libc++-@LLVM_VERSION@
usr/lib/llvm-@LLVM_VERSION@/bin/g++-libc++ usr/bin/g++-libc++-@LLVM_VERSION@
#!/bin/sh
# postinst script for libc++
#
# see: dh_installdeb(1)
set -e
# summary of how this script can be called:
# * <postinst> `configure' <most-recently-configured-version>
# * <old-postinst> `abort-upgrade' <new version>
# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
# <new-version>
# * <postinst> `abort-remove'
# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
# <failed-install-package> <version> `removing'
# <conflicting-package> <version>
# for details, see http://www.debian.org/doc/debian-policy/ or
# the debian-policy package
PRIORITY=5
case "$1" in
configure)
update-alternatives --install /usr/bin/c++ c++ /usr/bin/clang++-libc++ $PRIORITY
;;
abort-upgrade|abort-remove|abort-deconfigure)
;;
*)
echo "postinst called with unknown argument \`$1'" >&2
exit 1
;;
esac
# dh_installdeb will replace this with shell code automatically
# generated by other debhelper scripts.
#DEBHELPER#
exit 0
#!/bin/sh
# prerm script for libc++
#
# see: dh_installdeb(1)
set -e
# summary of how this script can be called:
# * <prerm> `remove'
# * <old-prerm> `upgrade' <new-version>
# * <new-prerm> `failed-upgrade' <old-version>
# * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
# * <deconfigured's-prerm> `deconfigure' `in-favour'
# <package-being-installed> <version> `removing'
# <conflicting-package> <version>
# for details, see http://www.debian.org/doc/debian-policy/ or
# the debian-policy package
case "$1" in
remove|upgrade|deconfigure)
update-alternatives --remove c++ /usr/bin/clang++-libc++
;;
failed-upgrade)
;;
*)
echo "prerm called with unknown argument \`$1'" >&2
exit 1
;;
esac
# dh_installdeb will replace this with shell code automatically
# generated by other debhelper scripts.
#DEBHELPER#
exit 0
......@@ -6,7 +6,7 @@ VERSION=7
DETAILED_VERSION=7~+rc1-1~exp3
echo "To install everything:"
echo "sudo dpkg -i libomp5-${VERSION}_${DETAILED_VERSION}_amd64.deb libomp-${VERSION}-dev_${DETAILED_VERSION}_amd64.deb lldb-${VERSION}_${DETAILED_VERSION}_amd64.deb python-lldb-${VERSION}_${DETAILED_VERSION}_amd64.deb libllvm7_${DETAILED_VERSION}_amd64.deb llvm-${VERSION}-dev_${DETAILED_VERSION}_amd64.deb liblldb-${VERSION}-dev_${DETAILED_VERSION}_amd64.deb libclang1-${VERSION}_${DETAILED_VERSION}_amd64.deb libclang-common-${VERSION}-dev_${DETAILED_VERSION}_amd64.deb llvm-${VERSION}_${DETAILED_VERSION}_amd64.deb liblldb-${VERSION}_${DETAILED_VERSION}_amd64.deb llvm-${VERSION}-runtime_${DETAILED_VERSION}_amd64.deb lld-${VERSION}_${DETAILED_VERSION}_amd64.deb libfuzzer-${VERSION}-dev_${DETAILED_VERSION}_amd64.deb libclang-${VERSION}-dev_${DETAILED_VERSION}_amd64.deb libc++-${VERSION}-dev_${DETAILED_VERSION}_amd64.deb libc++1-${VERSION}_${DETAILED_VERSION}_amd64.deb libc++-${VERSION}-helpers_${DETAILED_VERSION}_all.deb clang-${VERSION}_${DETAILED_VERSION}_amd64.deb"
echo "sudo dpkg -i libomp5-${VERSION}_${DETAILED_VERSION}_amd64.deb libomp-${VERSION}-dev_${DETAILED_VERSION}_amd64.deb lldb-${VERSION}_${DETAILED_VERSION}_amd64.deb python-lldb-${VERSION}_${DETAILED_VERSION}_amd64.deb libllvm7_${DETAILED_VERSION}_amd64.deb llvm-${VERSION}-dev_${DETAILED_VERSION}_amd64.deb liblldb-${VERSION}-dev_${DETAILED_VERSION}_amd64.deb libclang1-${VERSION}_${DETAILED_VERSION}_amd64.deb libclang-common-${VERSION}-dev_${DETAILED_VERSION}_amd64.deb llvm-${VERSION}_${DETAILED_VERSION}_amd64.deb liblldb-${VERSION}_${DETAILED_VERSION}_amd64.deb llvm-${VERSION}-runtime_${DETAILED_VERSION}_amd64.deb lld-${VERSION}_${DETAILED_VERSION}_amd64.deb libfuzzer-${VERSION}-dev_${DETAILED_VERSION}_amd64.deb libclang-${VERSION}-dev_${DETAILED_VERSION}_amd64.deb libc++-${VERSION}-dev_${DETAILED_VERSION}_amd64.deb libc++1-${VERSION}_${DETAILED_VERSION}_amd64.deb clang-${VERSION}_${DETAILED_VERSION}_amd64.deb"
if test ! -f /usr/bin/llvm-config-$VERSION; then
......@@ -262,11 +262,6 @@ int main() {
clang++-$VERSION -std=c++17 -stdlib=libc++ foo.cpp -lc++experimental -lc++fs -o o
./o > /dev/null
/usr/lib/llvm-7/bin/clang++-libc++ -std=c++17 foo.cpp -lc++experimental -lc++fs -o o
./o > /dev/null
clang++-libc++-$VERSION -std=c++17 foo.cpp -lc++experimental -lc++fs -o o
./o > /dev/null
g++ -nostdinc++ -I/usr/lib/llvm-$VERSION/bin/../include/c++/v1/ -L/usr/lib/llvm-$VERSION/lib/ \
foo.cpp -nodefaultlibs -std=c++17 -lc++ -lc++abi -lm -lc -lgcc_s -lgcc
./o > /dev/null
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment