Commit 5f48e173 authored by Jonas Smedegaard's avatar Jonas Smedegaard

Merge commit '0827004f' into debian/buster

parents 657464e8 0827004f
sugar-toolkit-gtk3 (0.112-2) unstable; urgency=medium
sugar-toolkit-gtk3 (0.112-3) unstable; urgency=medium
* Add patch cherry-picked upstream
to fix handle new OpenSSH DSA key format.
......@@ -6,6 +6,20 @@ sugar-toolkit-gtk3 (0.112-2) unstable; urgency=medium
-- Jonas Smedegaard <dr@jones.dk> Sat, 11 May 2019 13:58:36 +0200
sugar-toolkit-gtk3 (0.112-2) unstable; urgency=medium
* Add 0001-sugar3.speech-remove-GConf-compatibility-support.patch
* Drop unused gir1.2-gconf-2.0 dependency.
* Update VCS URLs to match the repository in salsa.
* debian/rules: override s/libfribidi0-dev/libfribidi-dev/ in
d-shlibmove to address #895235
* libsugarext-dbg: move Priority: extra to Priority: optional to follow
Policy.
* Declare compliance with Debian Policy 4.1.4.
-- Santiago Ruano Rincón <santiago@debian.org> Mon, 14 May 2018 14:14:11 +0200
sugar-toolkit-gtk3 (0.112-1) unstable; urgency=medium
[ upstream ]
......
......@@ -29,9 +29,9 @@ Build-Depends: cdbs,
linux-libc-dev [linux-any],
hurd-dev [hurd-any],
d-shlibs (>= 0.59~)
Standards-Version: 4.1.1
Vcs-Git: https://anonscm.debian.org/git/pkg-sugar/sugar-toolkit-gtk3.git
Vcs-Browser: https://anonscm.debian.org/git/pkg-sugar/sugar-toolkit-gtk3.git
Standards-Version: 4.1.4
Vcs-Git: https://salsa.debian.org/pkg-sugar-team/sugar-toolkit-gtk3.git
Vcs-Browser: https://salsa.debian.org/pkg-sugar-team/sugar-toolkit-gtk3
Homepage: http://wiki.sugarlabs.org/go/Sugar
Package: libsugarext0
......@@ -94,7 +94,7 @@ Description: Sugar Learning Platform - toolkit development files
Package: libsugarext-dbg
Section: debug
Priority: extra
Priority: optional
Architecture: any
Depends: ${misc:Depends},
libsugarext0 (= ${binary:Version}),
......
......@@ -6,8 +6,8 @@ Uploaders: Jonas Smedegaard <dr@jones.dk>,
Santiago Ruano Rincón <santiago@debian.org>
Build-Depends: @cdbs@
Standards-Version: 4.1.1
Vcs-Git: https://anonscm.debian.org/git/pkg-sugar/sugar-toolkit-gtk3.git
Vcs-Browser: https://anonscm.debian.org/git/pkg-sugar/sugar-toolkit-gtk3.git
Vcs-Git: https://salsa.debian.org/pkg-sugar-team/sugar-toolkit-gtk3.git
Vcs-Browser: https://salsa.debian.org/pkg-sugar-team/sugar-toolkit-gtk3
Homepage: http://wiki.sugarlabs.org/go/Sugar
Package: libsugarext0
......
From: James Cameron <quozl@laptop.org>
Date: Mon, 26 Mar 2018 14:35:28 +1100
Subject: sugar3.speech - remove GConf compatibility support
---
src/sugar3/speech.py | 5 -----
1 file changed, 5 deletions(-)
diff --git a/src/sugar3/speech.py b/src/sugar3/speech.py
index ef80d7a..674f587 100644
--- a/src/sugar3/speech.py
+++ b/src/sugar3/speech.py
@@ -345,11 +345,6 @@ class SpeechManager(GObject.GObject):
def save(self):
self._save_timeout_id = -1
- # DEPRECATED
- from gi.repository import GConf
- client = GConf.Client.get_default()
- client.set_int('/desktop/sugar/speech/pitch', self._pitch)
- client.set_int('/desktop/sugar/speech/rate', self._rate)
settings = Gio.Settings('org.sugarlabs.speech')
settings.set_int('pitch', self._pitch)
......@@ -3,3 +3,4 @@
1001_espeak-ng.patch
2002_ignore_debian_and_quilt-patches.patch
#2003_bundlebuilder_exit_nonzero_on_error.patch
0001-sugar3.speech-remove-GConf-compatibility-support.patch
......@@ -67,8 +67,7 @@ bdeps +=, linux-libc-dev [linux-any], hurd-dev [hurd-any]
# * gstreamer1.0-espeak used in sugar3.speech
# * gstreamer1.0-plugins-good (autoaudiosink) used in sugar3.speech
# TODO: relax dependencies for our own GIR when its API is stable
gir-deps = glib-2.0 gtk-3.0 gconf-2.0 gdkpixbuf-2.0 pango-1.0 rsvg-2.0
gir-deps += gconf-2.0 atspi-2.0
gir-deps = glib-2.0 gtk-3.0 gdkpixbuf-2.0 pango-1.0 rsvg-2.0 atspi-2.0
python-deps = gi gi-cairo dbus cairo telepathy dateutil decorator
depends = $(patsubst %,$(comma) python-%,$(python-deps))
depends +=, $(patsubst %,$(comma) gir1.2-%,$(gir-deps))
......@@ -114,6 +113,8 @@ binary-post-install/$(pkg-data)::
# and handle shared library install
CDBS_BUILD_DEPENDS += , d-shlibs (>= 0.59~)
binary-post-install/$(pkg-lib):: debian/stamp-local-shlibs-$(lib)
# the --override s/libfribidi0-dev/libfribidi-dev/ below is needed to
# address https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895235
debian/stamp-local-shlibs-$(lib): binary-install/$(pkg-lib)
d-shlibmove --commit \
--multiarch \
......@@ -121,6 +122,7 @@ debian/stamp-local-shlibs-$(lib): binary-install/$(pkg-lib)
--devunversioned --ignorelibdep \
--movedev debian/tmp/usr/share/gir-1.0 usr/share/ \
--extralib debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/libsugar-eventcontroller.so \
--override s/libfribidi0-dev/libfribidi-dev/ \
debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/$(lib).so
touch $@
clean::
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment