Commit 651b8493 authored by Bernd Zeimetz's avatar Bernd Zeimetz

- Bumping Standards-Version to 3.8.0

    * Create an empty userlist.txt in /etc/pgbouncer
  - debian/README.source:
    * Adding file to make the package conform to Standards Version 3.8.0.
  - debian/default:
    * Adding short explanation.
  - debian/README.Debian
    * Several spelling fixes.
parent 7fba6e8f
pgbouncer for Debian
--------------------
General usage information can be found in the site -
https://developer.skype.com/SkypeGarage/DbProjects/PgBouncer/UsageInfo.
General usage information can be found at
https://developer.skype.com/SkypeGarage/DbProjects/PgBouncer/UsageInfo.
Package-specific notes:
- The default directory for the socket file and PID file is
/var/run/postgresql, as is know from the postgresql package.
- The default directory for the socket and PID file is
/var/run/postgresql, as known from the postgresql package.
- The pgbouncer daemon is disabled by default, to enable it you need
to set START to 1 in /etc/default/pgbouncer.
- For default, pgbouncer is disable daemon. Change default value to "1" in /etc/default/pgbouncer to enable.
pgbouncer source for Debian
---------------------------------
* On Debian, dpatch is being used to manage patches at build time.
Please install the dpatch package and read
/usr/share/doc/dpatch/README.source.gz
if you'd like to know how to use it.
-- Bernd Zeimetz <bzed@debian.org> Fri, 26 Sep 2008 18:16:03 +0200
......@@ -11,6 +11,7 @@ pgbouncer (1.2.3-1) unstable; urgency=low
- debian/control: Depend on postgresql-common to make sure the postgres
user exists (Closes: #499521).
- Fixed init script, not using -n option anymore (Closes: #499522)
- Bumping Standards-Version to 3.8.0
* Adding myself to Uploaders.
* The following changes are a general cleanup of the package,
unfortunately these things were never detected by the former
......@@ -20,8 +21,6 @@ pgbouncer (1.2.3-1) unstable; urgency=low
* Fixing the long description, removing the copy of the short
description from it and switch to a better indenting.
* Removing extra blank lines.
* Keeping Standards-Version on 3.7.3 as the patch system is not
documented yet.
* pgbouncer supports PostgreSQL versions 7.4 and higher, changing the
Enhances field accordingly.
* Dropping Conflicts field again. It's not a problem to install
......@@ -39,6 +38,7 @@ pgbouncer (1.2.3-1) unstable; urgency=low
needs to stop before it. Changing to 'defaults 20 18' therefore.
* Don't install pgbouncer.ini.examples in the doc directory, use
dh_installexamples to install into the examples directory instead.
* Create an empty userlist.txt in /etc/pgbouncer
- debian/pgbouncer.8:
* Dropping file, upstream provides a manpage.
- debian/init:
......@@ -61,8 +61,14 @@ pgbouncer (1.2.3-1) unstable; urgency=low
more obvious.
- debian/patches/00list:
* Updated accordingly.
- debian/README.source:
* Adding file to make the package conform to Standards Version 3.8.0.
- debian/default:
* Adding short explanation.
- debian/README.Debian
* Several spelling fixes.
-- Bernd Zeimetz <bzed@debian.org> Fri, 26 Sep 2008 18:01:55 +0200
-- Bernd Zeimetz <bzed@debian.org> Fri, 26 Sep 2008 18:15:12 +0200
pgbouncer (1.1.2.1-1) unstable; urgency=low
......
# Set to 1 after you've configured pgbouncer in
# /etc/pgbouncer
START=0
......@@ -15,6 +15,7 @@ clean::
install/pgbouncer::
rm -f $(CURDIR)/debian/pgbouncer/usr/share/doc/pgbouncer/pgbouncer.ini
touch $(CURDIR)/debian/pgbouncer/usr/share/doc/pgbouncer/userlist.txt
binary-predeb/pgbouncer::
patch -p0 $(CURDIR)/debian/pgbouncer/etc/pgbouncer/pgbouncer.ini $(CURDIR)/debian/config.patch
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment