Commit b4b0446d authored by Christoph Berg's avatar Christoph Berg

postgresql-12 and later won't have plpython2 at all, take 3

parent c68e5e14
Pipeline #71074 failed with stage
in 7 minutes and 13 seconds
......@@ -67,7 +67,10 @@ if [ "${INSTALL:-}" ] && [ -z "${UNSHARED:-}" ]; then
case $DISTRO in
debian|ubuntu)
for v in $PG_VERSIONS; do
[ "$(perl -I. -le 'use PgCommon; print $PgCommon::have_python2')" = "1" ] && PYTHON2_PACKAGE=postgresql-plpython-$v
case $v in 8.*|9.*|10|11)
[ "$(perl -I. -le 'use PgCommon; print $PgCommon::have_python2')" = "1" ] && PYTHON2_PACKAGE=postgresql-plpython-$v
;;
esac
apt-get install -y \
postgresql-contrib-$v \
postgresql-plperl-$v \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment