Gemfile 532 Bytes
Newer Older
Ken Barber's avatar
Ken Barber committed
1 2 3
source 'https://rubygems.org'

gem 'facter'
4 5 6 7 8 9 10

group :test do
  # Pinning to work-around an incompatiblity with 2.14 in puppetlabs_spec_helper
  gem 'rspec', '2.13.0'
  gem 'puppetlabs_spec_helper', '0.4.1', :require => false

  gem 'puppet', :require => false
11

12
  gem 'mocha', '~> 1.0'
13 14

  # Since newer versions of rake are not supported, we pin
Ken Barber's avatar
Ken Barber committed
15 16
  case RUBY_VERSION
  when '1.8.5'
17
    gem 'rake', '<= 0.8.7'
Ken Barber's avatar
Ken Barber committed
18 19 20 21
  when '1.8.7'
    gem 'rake', '<= 10.1.1'
  else
    gem 'rake'
22 23 24 25
  end
end

group :acceptance do
26
  gem 'beaker', '~> 1.7'
27
end