• Ken Barber's avatar
    PDB-308 Drop 2.7.x support · 40c42e30
    Ken Barber authored
    This patch removes support for Puppet 2.7.x in several ways:
    
    * New check for every entry point in terminus will return an error if the
      version of Puppet is not supported. This is done in a 'soft' manner to
      avoid Puppet from not working.
    * Documentation now only references Puppet 3
    * Documentation now states only latest version of Puppet is supported
    * Packaging now has hard dependencies on the latest version of Puppet
    * Contrib gemspec has been updated
    * Gemfile for tests have been updated
    Signed-off-by: default avatarKen Barber <ken@bob.sh>
    40c42e30
index.markdown 5.78 KB