Commit 04b90918 authored by Ken Barber's avatar Ken Barber

Merge pull request #856 from senior/ticket/master/pdb-271-remove-jdk-16-from-docs

(PDB-271) Update docs to reflect removal of JDK 1.6 support
parents fd33e1c1 a6f42afd
......@@ -61,15 +61,15 @@ In future versions, PuppetDB will store historical catalogs for every node.
System Requirements
-----
### \*nix Server with JDK 1.6+
### \*nix Server with JDK 1.7+
#### Standard Install: RHEL, CentOS, Debian, Ubuntu, or Fedora
Puppet Labs provides packages and a Puppet module for PuppetDB which simplify setup of its SSL certificates and init scripts. These packages are available for the following operating systems:
* Red Hat Enterprise Linux 5 or 6 or any distro derived from it (including CentOS)
* Debian Squeeze, Wheezy, or Sid
* Ubuntu 12.10, 12.04 LTS, 10.04 LTS, 11.10
* Debian Squeeze (see [here](https://wiki.debian.org/JavaPackage) for JDK 1.7 packages), Wheezy, or Sid
* Ubuntu 12.10, 12.04 LTS, 10.04 LTS (see [here](https://wiki.debian.org/JavaPackage) for JDK 1.7 packages), 11.10
* Fedora 18, 19 or 20
[See here for instructions for installing via the PuppetDB puppet module.][install_via_module]
......@@ -78,7 +78,7 @@ Puppet Labs provides packages and a Puppet module for PuppetDB which simplify se
#### Custom Install: Any Unix-like OS
If you're willing to do some manual configuration, PuppetDB can run on any Unix-like OS with JDK 1.6 or higher, including:
If you're willing to do some manual configuration, PuppetDB can run on any Unix-like OS with JDK 1.7 or higher, including:
* Recent MacOS X versions (using built-in Java support)
* Nearly any Linux distribution (using vendor's OpenJDK packages)
......
......@@ -29,7 +29,7 @@ Step 1: Install Prerequisites
Use your system's package tools to ensure that the following prerequisites are installed:
* Facter, version 1.6.8 or higher <!-- TODO find the actual required version. Problem was a rake aborted! undefined method `downcase' for nil:NilClass error. -->
* JDK 1.6 or higher
* JDK 1.7 or higher
* [Leiningen][]
* Git (for checking out the source code)
......
......@@ -83,9 +83,9 @@ previous experience with the language on our team.
## Which versions of Java are supported?
The officially supported versions are OpenJDK and Oracle JDK, versions 1.6 and
1.7. Other versions may work and issues will be addressed on a best effort
basis, but support is not guaranteed.
The officially supported versions are OpenJDK 1.7 and Oracle JDK
1.7. Other versions may work and issues will be addressed on a best
effort basis, but support is not guaranteed.
## Which databases are supported?
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment