Commit 281fb918 authored by Rob Browning's avatar Rob Browning

(PDB-1612) Raise min puppet version to 3.8.1

parent 0e70573f
......@@ -18,5 +18,5 @@ Gem::Specification.new do |gem|
gem.require_paths = ["lib"]
gem.add_runtime_dependency 'json'
gem.add_runtime_dependency 'puppet', ['>= 3.7.3', '<5.0']
gem.add_runtime_dependency 'puppet', ['>= 3.8.1', '<5.0']
end
......@@ -88,9 +88,13 @@ If you're willing to do some manual configuration, PuppetDB can run on any Unix-
[See here for advanced installation instructions.][install_advanced]
### Puppet 3.7.3
### Puppet 3.8.1
Your site's puppet masters must be running Puppet 3.7.3 or later. [You will need to connect your puppet masters to PuppetDB after installing it][connect]. If you wish to use PuppetDB with [standalone nodes that are running puppet apply][apply], every node must be running 3.7.3 or later.
Your site's puppet masters must be running Puppet 3.8.1 or
later. [You will need to connect your puppet masters to PuppetDB after installing it][connect].
If you wish to use PuppetDB with
[standalone nodes that are running puppet apply][apply], every node
must be running 3.8.1 or later.
> #### Note about Puppet Enterprise
>
......
ezbake: {
pe: {}
foss: {
redhat: { dependencies: ["puppet >= 3.7.3", "puppet < 5.0.0"],
redhat: { dependencies: ["puppet >= 3.8.1", "puppet < 5.0.0"],
postinst: ["/opt/puppetlabs/server/bin/puppetdb ssl-setup"] },
debian: { dependencies: ["puppet (>= 3.7.3-1puppetlabs1) | puppet-agent", "puppet (<< 5.0.0-1puppetlabs1) | puppet-agent"],
debian: { dependencies: ["puppet (>= 3.8.1-1puppetlabs1) | puppet-agent",
"puppet (<< 5.0.0-1puppetlabs1) | puppet-agent"],
postinst: ["/opt/puppetlabs/server/bin/puppetdb ssl-setup"] }
}
}
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment