Commit 2d9b55b8 authored by wkalt's avatar wkalt

(maint) pin i18n

activesupport calls in the latest i18n, which drops support for Ruby
1.8.7 and breaks acceptance tests on Ubuntu 12.04.  This PR pins to a lower
version with 1.8.7 support.
parent 64c4cfde
......@@ -7,6 +7,9 @@ gem 'facter'
case RUBY_VERSION
when '1.8.7'
gem 'rake', '<= 10.1.1'
# activesupport calls in the latest i18n, which drops 1.8.7. This pins to
# a lower version
gem 'i18n', '~> 0.6.11'
else
gem 'rake'
end
......
......@@ -76,6 +76,9 @@ step "Install rubygems and sqlite3 on master" do
# we skip.
else
on master, "apt-get install -y rubygems ruby-dev libsqlite3-dev"
# this is to get around the activesupport dependency on Ruby 1.9.3 for
# Ubuntu 12.04. We can remove it when we drop support for 1.8.7.
on master, "gem install i18n -v 0.6.11"
on master, "gem install activerecord -v 3.2.17 --no-ri --no-rdoc -V --backtrace"
on master, "gem install sqlite3 -v 1.3.9 --no-ri --no-rdoc -V --backtrace"
end
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment