Commit 3c383028 authored by Rob Browning's avatar Rob Browning

(PDB-3917) Gemfile: refer to puppet via :ref not :branch

This should be more appropriate, since we'll want to be able to use
tags and hashes too.
parent 94050b6d
source ENV['GEM_SOURCE'] || "https://rubygems.org"
puppet_branch = ENV['PUPPET_VERSION'] || "master"
puppet_ref = ENV['PUPPET_VERSION'] || "master"
oldest_supported_puppet = "5.0.0"
beaker_version = ENV['BEAKER_VERSION']
......@@ -35,14 +35,14 @@ group :test do
# docker-api 1.32.0 requires ruby 2.0.0
gem 'docker-api', '1.31.0'
case puppet_branch
case puppet_ref
when "latest"
gem 'puppet', ">= #{oldest_supported_puppet}", :require => false
when "oldest"
gem 'puppet', oldest_supported_puppet, :require => false
else
gem 'puppet', :git => 'https://github.com/puppetlabs/puppet.git',
:branch => puppet_branch, :require => false
:ref => puppet_ref, :require => false
end
gem 'mocha', '~> 1.0'
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment