...
 
Commits (5)
beautifulsoup4 (4.6.3-2) UNRELEASED; urgency=medium
beautifulsoup4 (4.6.3-2) unstable; urgency=medium
[ Ondřej Nový ]
* Use 'python3 -m sphinx' instead of sphinx-build for building docs
-- Ondřej Nový <onovy@debian.org> Mon, 27 Aug 2018 15:13:23 +0200
[ Stefano Rivera ]
* Use pybuild's --name feature to place files in the right binary package.
* Bump Standards-Version to 4.3.0, no changes needed.
* Bump debhelper compat to 11.
-- Stefano Rivera <stefanor@debian.org> Sun, 30 Dec 2018 19:21:18 +0100
beautifulsoup4 (4.6.3-1) unstable; urgency=medium
......
......@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Uploaders: Stefano Rivera <stefanor@debian.org>
Build-Depends:
debhelper (>= 10),
debhelper (>= 11),
dh-python,
pypy (>= 1.7),
pypy-setuptools,
......@@ -15,7 +15,7 @@ Build-Depends:
python3-all (>= 3.1.2),
python3-lxml,
python3-setuptools
Standards-Version: 4.2.0
Standards-Version: 4.3.0
Homepage: https://www.crummy.com/software/BeautifulSoup
Vcs-Git: https://salsa.debian.org/python-team/modules/beautifulsoup4.git
Vcs-Browser: https://salsa.debian.org/python-team/modules/beautifulsoup4
......
/usr/lib/pypy/dist-packages/
/usr/lib/python2.*/*-packages
/usr/lib/python3*/*-packages
#!/usr/bin/make -f
export PYBUILD_NAME=bs4
%:
dh $@ --with python2,python3,pypy,sphinxdoc --buildsystem=pybuild
......@@ -13,3 +15,7 @@ override_dh_auto_clean:
override_dh_installchangelogs:
dh_installchangelogs NEWS.txt
override_dh_installdocs:
dh_installdocs -p python-bs4-doc --doc-main-package=python-bs4-doc
dh_installdocs --remaining-packages