Commit b858e1fe authored by Tristan Seligmann's avatar Tristan Seligmann

* New upstream release.

  - Fix a potential security issue when running Python in -O mode.
parent 79b1963a
python-cryptography (1.0.2-1) unstable; urgency=medium
* New upstream release.
- Fix a potential security issue when running Python in -O mode.
-- Tristan Seligmann <mithrandi@debian.org> Mon, 28 Sep 2015 06:36:07 +0200
python-cryptography (1.0.1-4) unstable; urgency=medium
* Remove cffi from requires.txt after dh_python[23] runs
......
......@@ -8,8 +8,8 @@ Build-Depends:
libssl-dev,
python-all-dev,
python-cffi (>= 1.1.0~),
python-cryptography-vectors (<< 1.0.2~),
python-cryptography-vectors (>= 1.0.1~),
python-cryptography-vectors (<< 1.0.3~),
python-cryptography-vectors (>= 1.0.2~),
python-enum34,
python-idna (>= 2.0~),
python-ipaddress,
......@@ -21,8 +21,8 @@ Build-Depends:
python-six (>= 1.4.1~),
python3-all-dev,
python3-cffi (>= 1.1.0~),
python3-cryptography-vectors (<< 1.0.2~),
python3-cryptography-vectors (>= 1.0.1~),
python3-cryptography-vectors (<< 1.0.3~),
python3-cryptography-vectors (>= 1.0.2~),
python3-idna (>= 2.0~),
python3-iso8601,
python3-pretend,
......
......@@ -21,7 +21,7 @@ override_dh_python2:
# Remove "cffi" from requires after dh_python has seen it (so that the
# pydist file takes effect), because it is not actually needed at
# runtime.
sed -i '/^cffi$$/d' \
sed -i '/^cffi/d' \
debian/python-cryptography/usr/lib/python*/dist-packages/cryptography*.egg-info/requires.txt
......@@ -29,5 +29,5 @@ override_dh_python3:
dh_python3
rm -rf debian/python3-cryptography/usr/lib/python3.?
# See comment in override_dh_python2
sed -i '/^cffi$$/d' \
sed -i '/^cffi/d' \
debian/python3-cryptography/usr/lib/python3/dist-packages/cryptography*.egg-info/requires.txt
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment