Commit f8f041c6 authored by Luke Faraone's avatar Luke Faraone

Imported Debian patch 0.3.0-1

This is a Bazaar control directory.
Do not change any files in this directory.
See http://bazaar-vcs.org/ for more information about Bazaar.
Bazaar-NG meta directory, format 1
parent_location = bzr+ssh://bazaar.launchpad.net/%7Egasp-dev/gasp-code/pycairo/
Bazaar Branch Format 6 (bzr 0.15)
40 jboisture@jboisture-desktop-20090723040020-0yvlaal44hlcs6tb
BZR conflict list format 1
Bazaar Working Tree Format 4 (bzr 0.15)
Bazaar pack repository format 1 (needs bzr 0.92)
Bazaar Graph Index 1
node_ref_lists=0
key_elements=1
len=0
......@@ -2,6 +2,7 @@ Contributors
============
Principal Developer:
Jamie Boisture
James Hancock
Major Contributors:
......
python-gasp (0.3.0-1) unstable; urgency=low
* New upstream version
* Update Maintainer email address
* Fixed copyright file to use the © symbol
* Switch to pysupport
* Fix get-orig-source in debian/rules
* Fixed setup.py so that images are installed in the proper location.
* debian/control: Added dependency on python-gobject, python-gtk2, and
python-multiprocessing.
-- Luke Faraone <luke@faraone.cc> Mon, 27 Jul 2009 21:16:02 -0400
python-gasp (0.2.1~bzr65-1) unstable; urgency=low
* Initial release. (Closes: #506501)
......
Source: python-gasp
Section: python
Priority: optional
Maintainer: Luke Faraone <lfaraone@ubuntu.com>
Maintainer: Luke Faraone <luke@faraone.cc>
Uploaders: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Build-Depends: python (>= 2.5), debhelper (>= 5), cdbs (>= 0.4.43), python-setuptools,
Build-Depends-indep: python-dev (>= 2.3.5-11), python-central (>= 0.5.0), patchutils, bzr
Standards-Version: 3.8.0
Build-Depends: python (>= 2.4), debhelper (>= 5), cdbs (>= 0.4.49), python-setuptools,
Build-Depends-indep: python-support (>= 0.5.3), patchutils, bzr
Standards-Version: 3.8.2
Homepage: https://launchpad.net/gasp
Vcs-Svn: svn://svn.debian.org/python-modules/packages/python-gasp/trunk
Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/python-gasp/trunk/
XS-Python-Version: all
Package: python-gasp
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}, python-pygame
Depends: ${misc:Depends}, ${python:Depends}, python-cairo (>= 1.4), python-gtk2, python-gobject, python-multiprocessing
Provides: ${python:Provides}
XB-Python-Version: ${python:Versions}
Description: procedural Python graphics library for beginning programmers
GASP is a wrapper around the Pygame SDL library which makes writing graphical
applications in Python easy for beginners, requiring no knowledge of classes
or instances.
GASP is a wrapper around the Python Cairo Graphics library which makes writing
graphical applications in Python easy for beginners, requiring little prior
knowledge of object-oriented programming.
This package was debianized by Luke Faraone <lfaraone@ubuntu.com> on
This package was debianized by Luke Faraone <luke@faraone.cc> on
Friday November 21, 2008 22:30:00 -0500.
It was downloaded from https://launchpad.net/gasp-code/
......@@ -40,5 +40,5 @@ version.
On Debian systems, the complete text of the GPL v3 can be found here:
/usr/share/common-licenses/GPL-3
The Debian packaging is (C) 2008, Luke Faraone <lfaraone@ubuntu.com> and is
The Debian packaging is © 2008, 2009 Luke Faraone <luke@faraone.cc> and is
licensed under the GPL version 3 or later. See above.
diff -Nur -x '*.orig' -x '*~' trunk/gasp/setup.py trunk.new/gasp/setup.py
--- trunk/gasp/setup.py 2009-07-27 19:11:15.000000000 -0400
+++ trunk.new/gasp/setup.py 2009-07-27 19:30:58.000000000 -0400
@@ -24,6 +24,8 @@
'Natural Language :: English',
'Operating System :: OS Independent',
'Topic :: Education :: Computer Aided Instruction (CAI)'],
+
+ data_files=[('share/python-support/python-gasp/gasp/images', ['gasp/images/gasp.png',]),],
install_requires = [
'setuptools',
#!/usr/bin/make -f
DEB_PYTHON_SYSTEM=pycentral
DEB_PYTHON_SYSTEM=pysupport
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/python-distutils.mk
include /usr/share/cdbs/1/rules/simple-patchsys.mk
DEB_PYTHON_SETUP_CMD = gasp/setup.py
PACKAGE = python-gasp
BRANCH_LOC = lp:gasp-code
SRC_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)-.*/\1/p')
SVN_REVISION := $(shell echo $(SRC_VERSION) | sed 's/.\..\..~bzr//' )
TARBALL = $(PACKAGE)_$(SRC_VERSION).orig.tar.gz
.PHONY: get-orig-source
get-orig-source:
rm -rf $(TARBALL) $(TARBALL).cdbs-config_list
bzr export -r $(SVN_REVISION) $(TARBALL) $(BRANCH_LOC)
REV=$(shell dpkg-parsechangelog | sed -rne 's,^Version: .*bzr([^-]+).*,\1,p'); \
VER=$(shell dpkg-parsechangelog | sed -rne 's,^Version: ([^-]+).*,\1,p'); \
if [ x$$REV = x ]; then \
uscan --force-download --rename --repack --download-version=$$VER --destdir=.; \
else \
bzr export -r $$REV python-gasp_$$VER.orig.tar.gz lp:gasp-code; \
fi
This diff is collapsed.
This diff is collapsed.
......@@ -5,12 +5,12 @@ from setuptools import setup
setup(
name = 'gasp',
version = '0.2.1',
version = '0.3.x',
packages = ['gasp',
],
author = "James Hancock",
author_email = "jlhancock@gmail.com",
author = "Jamie Boisture and James Hancock",
author_email = "jamieboisture@gmail.com, jlhancock@gmail.com",
description = "GASP provides a simple, procedural graphics API for beginning students using Python",
license = "GPLv3+",
keywords = "gasp",
......@@ -26,7 +26,6 @@ setup(
'Topic :: Education :: Computer Aided Instruction (CAI)'],
install_requires = [
'pygame',
'setuptools',
],
)
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment