...
 
Commits (3)
python-pkginfo (1.4.2-2) UNRELEASED; urgency=medium
python-pkginfo (1.4.2-2) unstable; urgency=medium
[ Stefano Rivera ]
* Team upload
* Patch: metadata-2.1: setuptools >= 38.6 will use metadata version 2.1.
Expect that. (Closes: #894107)
* Bump Standards-Version to 4.2.1, no changes needed.
[ Ondřej Nový ]
* d/control: Remove ancient X-Python-Version field
* d/control: Remove ancient X-Python3-Version field
-- Ondřej Nový <onovy@debian.org> Mon, 14 May 2018 07:54:22 +0200
-- Stefano Rivera <stefanor@debian.org> Wed, 12 Sep 2018 17:43:16 +0300
python-pkginfo (1.4.2-1) unstable; urgency=medium
......
......@@ -7,10 +7,10 @@ Build-Depends: debhelper (>= 10),
dh-python,
python-all,
python3-all,
python-setuptools,
python3-setuptools,
python-setuptools (>= 38.6),
python3-setuptools (>= 38.6),
python3-sphinx
Standards-Version: 4.1.3
Standards-Version: 4.2.1
Homepage: https://pypi.python.org/pypi/pkginfo/
Vcs-Git: https://salsa.debian.org/python-team/modules/python-pkginfo.git
Vcs-Browser: https://salsa.debian.org/python-team/modules/python-pkginfo
......
From: Tres Seaver <tseaver@agendaless.com>
Date: Wed, 12 Sep 2018 17:39:32 +0300
Subject: With setuptools >= 38.6.0, we get metadata 2.1
Origin: upstream, https://bazaar.launchpad.net/~tseaver/pkginfo/trunk/revision/152
Bug-debian: https://bugs.debian.org/894107
---
pkginfo/tests/__init__.py | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/pkginfo/tests/__init__.py b/pkginfo/tests/__init__.py
index 1f95d9b..afdc8ed 100644
--- a/pkginfo/tests/__init__.py
+++ b/pkginfo/tests/__init__.py
@@ -32,7 +32,4 @@ def _checkClassifiers(testcase, installed):
def _defaultMetadataVersion():
- import sys
- if sys.version_info[:2] > (2, 6):
- return '1.1'
- return '1.0'
+ return '2.1'
......@@ -2,3 +2,4 @@
0002-Disable-test-test_ctor_w_package_no_PKG_INFO.patch
0003-Fix-typos-in-help.patch
0004-Sphinx-Alabaster-has-no-default.css.patch
metadata-2.1