Commit c86fdc92 authored by Alexandre Fayolle's avatar Alexandre Fayolle Committed by Sebastian Ramacher

Imported Debian patch 0.9.0-3

parent d82cd763
codespeak-lib (0.9.0-3) unstable; urgency=low
* Added missing build dependencies on subversion and ssh
* Patched code depending on the presence of .svn directories in apigen
-- Alexandre Fayolle <afayolle@debian.org> Wed, 21 Feb 2007 10:04:13 +0100
codespeak-lib (0.9.0-2) unstable; urgency=low
* Added patch to allow the apigen documentation to build even if the
......
......@@ -3,7 +3,7 @@ Section: python
Priority: optional
Maintainer: Guilherme Salgado <salgado@async.com.br>
Uploaders: Alexandre Fayolle <afayolle@debian.org>
Build-Depends: python-all-dev (>= 2.3.5-10), python-central (>= 0.5), debhelper (>= 5.0.37.1), dpatch, python-docutils, xsltproc, docbook-xsl
Build-Depends: python-all-dev (>= 2.3.5-10), python-central (>= 0.5), debhelper (>= 5.0.37.1), dpatch, python-docutils, xsltproc, docbook-xsl, subversion
XS-Python-Version: all
Standards-Version: 3.7.2
......@@ -13,7 +13,7 @@ Depends: ${python:Depends}, ${shlibs:Depends}
Conflicts: python-pylib, python2.3-codespeak-lib, python2.4-codespeak-lib
Replaces: python-pylib, python2.3-codespeak-lib, python2.4-codespeak-lib
Recommends: python-tkinter, python-docutils
Suggests: screen, rsync, graphviz, tetex-bin, gs-gpl|gs-esp, ps2eps
Suggests: screen, rsync, graphviz, tetex-bin, gs-gpl|gs-esp, ps2eps, subversion
Provides: ${python:Provides}
XB-Python-Version: ${python:Versions}
Description: The pylib library containing py.test, greenlets and other niceties
......
......@@ -178,6 +178,8 @@ def get_package_revision(packageroot, _revcache={}):
rev = None
if wc.check(versioned=True):
rev = py.path.svnwc(packageroot).info().rev
else:
rev = py.__package__.revision
_revcache[packageroot] = rev
if packageroot.basename == "py":
assert rev is not None
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment