Commit 45148619 authored by Ondřej Nový's avatar Ondřej Nový

Drop PyPy support

parent fc4a188d
......@@ -7,6 +7,7 @@ python-rply (0.7.4-4) UNRELEASED; urgency=medium
* d/control: Remove ancient X-Python3-Version field
* Convert git repository from git-dpm to gbp layout
* Use debhelper-compat instead of debian/compat.
* Drop PyPy support
-- Ondřej Nový <onovy@debian.org> Tue, 13 Feb 2018 10:03:17 +0100
......
......@@ -7,9 +7,6 @@ Build-Depends:
debhelper-compat (= 9),
devscripts,
dh-python,
pypy,
pypy-appdirs,
pypy-setuptools,
python,
python-appdirs,
python-setuptools,
......@@ -40,13 +37,3 @@ Description: pure Python based parser that also works with RPython (Python 3)
Bazzley's awesome PLY, with a new public API, and RPython support.
.
This package provides Python 3 bindings only.
Package: pypy-rply
Architecture: all
Depends: ${misc:Depends}, ${pypy:Depends}
Description: pure Python based parser that also works with RPython (PyPy)
This package provides a pure Python based parser generator, that also
works with RPython. It is a more-or-less direct port of David
Bazzley's awesome PLY, with a new public API, and RPython support.
.
This package provides PyPy bindings only.
appdirs pypy-appdirs; PEP386
......@@ -3,4 +3,4 @@ export PYTHONDONTWRITEBYTECODE=yes
export PYBUILD_NAME=rply
%:
dh $@ --with python2,python3,pypy --buildsystem=pybuild
dh $@ --with python2,python3 --buildsystem=pybuild
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment