Commit 4a705d09 authored by Ondřej Nový's avatar Ondřej Nový

Drop Python 2 support.

parent 53db9de9
python-rply (0.7.7-2) UNRELEASED; urgency=medium
* Drop Python 2 support.
-- Ondřej Nový <onovy@debian.org> Sun, 25 Aug 2019 09:13:45 +0200
python-rply (0.7.7-1) unstable; urgency=medium
* Team upload.
......
......@@ -7,10 +7,7 @@ Build-Depends:
debhelper-compat (= 12),
devscripts,
dh-python,
python,
python-appdirs,
python-setuptools,
python3,
python3-all,
python3-appdirs,
python3-setuptools,
Standards-Version: 4.4.0
......@@ -19,16 +16,6 @@ Vcs-Git: https://salsa.debian.org/python-team/modules/python-rply.git
Vcs-Browser: https://salsa.debian.org/python-team/modules/python-rply
Testsuite: autopkgtest-pkg-python
Package: python-rply
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}
Description: pure Python based parser that also works with RPython (Python 2)
This package provides a pure Python based parser generator, that also
works with RPython. It is a more-or-less direct port of David
Bazzley's awesome PLY, with a new public API, and RPython support.
.
This package provides Python 2 bindings only.
Package: python3-rply
Architecture: all
Depends: ${misc:Depends}, ${python3:Depends}
......
......@@ -3,4 +3,4 @@ export PYTHONDONTWRITEBYTECODE=yes
export PYBUILD_NAME=rply
%:
dh $@ --with python2,python3 --buildsystem=pybuild
dh $@ --with python3 --buildsystem=pybuild
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment