Commit c4795059 authored by Scott Kitterman's avatar Scott Kitterman

Update autopkgtests to use yaml.FullLoader to avoid deprecation warnings

* Update autopkgtests to use yaml.FullLoader to avoid deprecation warnings
  - https://github.com/yaml/pyyaml/wiki/PyYAML-yaml.load(input)-Deprecation
parent e7027e22
pyyaml (5.1.2-1) UNRELEASED; urgency=medium
pyyaml (5.1.2-1) unstable; urgency=medium
[ Ondřej Nový ]
* Use debhelper-compat instead of debian/compat.
......@@ -8,8 +8,10 @@ pyyaml (5.1.2-1) UNRELEASED; urgency=medium
* New upstream release
- Dropped all patches, incorporated in upstream release
* Update debian/copyright
* Update autopkgtests to use yaml.FullLoader to avoid deprecation warnings
- https://github.com/yaml/pyyaml/wiki/PyYAML-yaml.load(input)-Deprecation
-- Scott Kitterman <scott@kitterman.com> Sun, 04 Aug 2019 18:40:27 -0400
-- Scott Kitterman <scott@kitterman.com> Sun, 04 Aug 2019 19:00:21 -0400
pyyaml (3.13-2) unstable; urgency=medium
......
#!/bin/sh
set -eu
export PYTHONIOENCODING='utf-8'
python -c "import yaml; print yaml.load('\N{PILE OF POO}')"
python -c "import yaml; print yaml.load('\N{PILE OF POO}', Loader=yaml.FullLoader)"
python -c "import yaml; print yaml.dump('\N{PILE OF POO}', allow_unicode=True)"
#!/bin/sh
set -eu
export PYTHONIOENCODING='utf-8'
python3 -c "import yaml; print(yaml.load('\N{PILE OF POO}'))"
python3 -c "import yaml; print(yaml.load('\N{PILE OF POO}', Loader=yaml.FullLoader))"
python3 -c "import yaml; print(yaml.dump('\N{PILE OF POO}', allow_unicode=True))"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment