Commit e0e5d5df authored by Dmitry Shachnev's avatar Dmitry Shachnev

Make autopkgtests test the installed version of the package.

This is required by the autopkgtest specification.
parent 80f0e34e
......@@ -17,6 +17,7 @@ sphinx-argparse (0.2.2-1) UNRELEASED; urgency=medium
* Fix sphinx-build invocation in debian/rules.
* Prevent dh_compress from compressing changelog.html.
* Drop unneeded dh_auto_test override, rely on pybuild magic.
* Make autopkgtests test the installed version of the package.
-- ChangZhuo Chen (陳昌倬) <czchen@debian.org> Sun, 02 Jul 2017 20:56:18 +0800
......
Tests: python-sphinx-argparse
Depends: python-all, python-pytest, python-sphinx
Depends: python-all, python-pytest, python-sphinx, python-sphinx-argparse
Tests: python3-sphinx-argparse
Depends: python3-all, python3-pytest, python3-sphinx
Depends: python3-all, python3-pytest, python3-sphinx, python3-sphinx-argparse
#!/bin/sh
set -e
cp -r test "$AUTOPKGTEST_TMP/"
cd "$AUTOPKGTEST_TMP"
for py in $(pyversions -i); do echo "[*] testing $py:"; PYTHONPATH=. $py -Wd -m pytest -v -x 2>&1; done
#!/bin/sh
set -e
cp -r test "$AUTOPKGTEST_TMP/"
cd "$AUTOPKGTEST_TMP"
for py in $(py3versions -i); do echo "[*] testing $py:"; PYTHONPATH=. $py -Wd -m pytest -v -x 2>&1; done
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment