...
 
Commits (3)
sqlobject (3.7.0+dfsg-2) unstable; urgency=low
* Change section for sqlobject-admin script to utils (lintian warning).
* Add patch to work around overly tight formencode requirement in the
setuptools files.
* Update Standards-Version to 4.3.0 (no changes needed).
-- Neil Muller <drnlmuller+debian@gmail.com> Sat, 05 Jan 2019 18:09:48 +0200
sqlobject (3.7.0+dfsg-1) unstable; urgency=low
[Ondřej Nový ]
......
......@@ -18,7 +18,7 @@ Build-Depends: debhelper (>= 11),
python3-pytest
Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Uploaders: Neil Muller <drnlmuller+debian@gmail.com>
Standards-Version: 4.2.1
Standards-Version: 4.3.0
Vcs-Git: https://salsa.debian.org/python-team/modules/sqlobject.git
Vcs-Browser: https://salsa.debian.org/python-team/modules/sqlobject
Homepage: http://www.sqlobject.org
......@@ -114,6 +114,7 @@ Description: Documentation for SQLObject, a Python object relational manager for
Package: sqlobject-admin
Architecture: all
Section: utils
Depends: python3-sqlobject (= ${source:Version}),
${misc:Depends},
${python3:Depends}
......
From: Neil Muller <Neil Muller drnlmuller+debian@gmail.com>
From: Neil Muller <drnlmuller+debian@gmail.com>
Date: Sat, 13 Oct 2018 12:06:33 +0200
Subject: Remove docs from installed files
......
From: Neil Muller <drnlmuller+debian@gmail.com>
Date: Sat, 5 Jan 2019 15:57:51 +0200
Subject: Change the formencode versions to work with the debian version.
The issues with FormEncode 1.3.0 that the requires are trying
to avoid do not apply to the debian package, and keeping this
requirement in place can cause problems with packages using
the debian versions, so we change the requirement to 1.3.0 or later.
---
SQLObject.egg-info/requires.txt | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/SQLObject.egg-info/requires.txt b/SQLObject.egg-info/requires.txt
index 601beb5..a9708e5 100644
--- a/SQLObject.egg-info/requires.txt
+++ b/SQLObject.egg-info/requires.txt
@@ -1,10 +1,10 @@
PyDispatcher>=2.0.4
[:python_version == "2.7"]
-FormEncode!=1.3.0,>=1.1.1
+FormEncode>=1.3.0
[:python_version >= "3.4"]
-FormEncode>=1.3.1
+FormEncode>=1.3.0
[adodbapi]
adodbapi
remove_pkg_resources
replace_logos
0004-Remove-docs-from-installed-files.patch
0005-Change-the-formencode-versions-to-work-with-the-debi.patch