Use alternatives for subvertpy-fast-export.

parent f32d92e1
#!/bin/sh -e
update-alternatives --install /usr/bin/subvertpy-fast-export subvertpy-fast-export /usr/bin/subvertpy2-fast-export 10
#DEBHELPER#
#!/bin/sh -e
#DEBHELPER#
case "$1" in
remove|deconfigure)
update-alternatives --remove subvertpy-fast-export /usr/bin/subvertpy2-fast-export
;;
*)
esac
#!/bin/sh -e
update-alternatives --install /usr/bin/subvertpy-fast-export subvertpy-fast-export /usr/bin/subvertpy3-fast-export 10
#DEBHELPER#
#!/bin/sh -e
#DEBHELPER#
case "$1" in
remove|deconfigure)
update-alternatives --remove subvertpy-fast-export /usr/bin/subvertpy3-fast-export
;;
*)
esac
......@@ -31,6 +31,10 @@ override_dh_auto_install:
debian/python-subvertpy/usr/share/doc/python-subvertpy
cp -a apidocs debian/python-subvertpy/usr/share/doc/python-subvertpy/api
cp -a apidocs debian/python3-subvertpy/usr/share/doc/python3-subvertpy/api
mv debian/python3-subvertpy/usr/bin/subvertpy-fast-export \
debian/python3-subvertpy/usr/bin/subvertpy3-fast-export
mv debian/python-subvertpy/usr/bin/subvertpy-fast-export \
debian/python-subvertpy/usr/bin/subvertpy2-fast-export
override_dh_strip:
dh_strip -p python-subvertpy --dbgsym-migration='python-subvertpy-dbg (<< 0.9.3-1)'
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment