Commit 0fef9342 authored by Holger Levsen's avatar Holger Levsen

reproducible Debian: use amd64 kernels on all i386 nodes (Closes: #875990

Signed-off-by: Holger Levsen's avatarHolger Levsen <holger@layer-acht.org>
parent 12c4b091
deb http://deb.debian.org/debian/ stretch main contrib non-free
#deb-src http://deb.debian.org/debian/ stretch main contrib non-free
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
#deb-src http://deb.debian.org/debian/ stretch-updates main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
#deb-src http://security.debian.org/ stretch/updates main contrib non-free
deb http://deb.debian.org/debian/ stretch-backports main contrib non-free
#deb-src http://deb.debian.org/debian/ stretch-backports main contrib non-free
# workaround for i386 kernel bugs #875990 + #876035
deb http://deb.debian.org/debian-security jessie/updates main
deb http://deb.debian.org/debian jessie main
deb http://deb.debian.org/debian/ stretch main contrib non-free
#deb-src http://deb.debian.org/debian/ stretch main contrib non-free
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
#deb-src http://deb.debian.org/debian/ stretch-updates main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
#deb-src http://security.debian.org/ stretch/updates main contrib non-free
deb http://deb.debian.org/debian/ stretch-backports main contrib non-free
#deb-src http://deb.debian.org/debian/ stretch-backports main contrib non-free
# workaround for i386 kernel bugs #875990 + #876035
deb http://deb.debian.org/debian-security jessie/updates main
deb http://deb.debian.org/debian jessie main
......@@ -469,11 +469,12 @@ if [ -f /etc/debian_version ] ; then
$UP2DATE || sudo apt-get install mock
fi
# for varying kernels:
# - we use bpo kernels on pb-build5+15 (and the default i386 kernel on pb-build2+12-i386)
# - we use the default amd64 kernel on pb-build1+11 (and the default amd64 kernel on pb-build6+16-i386)
# - we use bpo kernels on pb-build5+15 (and the default amd64 kernel on pb-build6+16-i386)
if [ "$HOSTNAME" = "profitbricks-build5-amd64" ] || [ "$HOSTNAME" = "profitbricks-build15-amd64" ] ; then
$UP2DATE || sudo apt-get install -t stretch-backports linux-image-amd64
elif [ "$HOSTNAME" = "profitbricks-build6-i386" ] || [ "$HOSTNAME" = "profitbricks-build16-i386" ] ; then
elif [ "$HOSTNAME" = "profitbricks-build6-i386" ] || [ "$HOSTNAME" = "profitbricks-build16-i386" ] \
|| [ "$HOSTNAME" = "profitbricks-build2-i386" ] || [ "$HOSTNAME" = "profitbricks-build12-i386" ] ; then
# we dont vary the kernel on i386 atm, see #875990 + #876035
$UP2DATE || sudo apt-get install linux-image-amd64
fi
# only needed on the main nodes
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment