Commit 79d5a13c authored by Holger Levsen's avatar Holger Levsen

reproducible: refactor and turn understood issues into warnings

Signed-off-by: Holger Levsen's avatarHolger Levsen <holger@layer-acht.org>
parent f30bf728
......@@ -23,8 +23,10 @@ check_pypi() {
elif dpkg --compare-versions "$DIFFOSCOPE_IN_DEBIAN" gt "$DIFFOSCOPE_IN_PYPI" ; then
echo "Fail: diffoscope in Debian: $DIFFOSCOPE_IN_DEBIAN"
echo "Fail: diffoscope in PyPI: $DIFFOSCOPE_IN_PYPI"
irc_message debian-reproducible "It seems diffoscope $DIFFOSCOPE_IN_DEBIAN is not available on PyPI, which only has $DIFFOSCOPE_IN_PYPI."
exit 1
WARNING="It seems diffoscope $DIFFOSCOPE_IN_DEBIAN is not available on PyPI, which only has $DIFFOSCOPE_IN_PYPI."
irc_message debian-reproducible "$WARNING"
echo "Warning: $WARNING"
exit 0
else
echo "diffoscope in Debian: $DIFFOSCOPE_IN_DEBIAN"
echo "diffoscope in PyPI: $DIFFOSCOPE_IN_PYPI"
......@@ -45,8 +47,10 @@ check_whohas() {
elif dpkg --compare-versions "$DIFFOSCOPE_IN_DEBIAN" gt "$DIFFOSCOPE_IN_WHOHAS" ; then
echo "Fail: diffoscope in Debian: $DIFFOSCOPE_IN_DEBIAN"
echo "Fail: diffoscope in $DISTRIBUTION: $DIFFOSCOPE_IN_WHOHAS"
irc_message debian-reproducible "It seems diffoscope $DIFFOSCOPE_IN_DEBIAN is not available in $DISTRIBUTION, which only has $DIFFOSCOPE_IN_WHOHAS."
exit 1
WARNING="It seems diffoscope $DIFFOSCOPE_IN_DEBIAN is not available in $DISTRIBUTION, which only has $DIFFOSCOPE_IN_WHOHAS."
irc_message debian-reproducible "$WARNING"
echo "Warning: $WARNING"
exit 0
else
# FIXME: archlinux package version will be greater than Debian: 52-1 vs 52
echo "diffoscope in Debian: $DIFFOSCOPE_IN_DEBIAN"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment