...
 
Commits (2)
......@@ -2,6 +2,7 @@
<xsl:stylesheet
xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
xmlns="http://www.w3.org/1999/xhtml"
xmlns:str="http://exslt.org/strings"
version="1.0">
<xsl:template name="issue-nmu">
......@@ -102,10 +103,12 @@
<xsl:template name="issue-outdate-stdver">
<xsl:if test="standards-version!='' and not(starts-with(standards-version, $lastsv))">
<xsl:variable name="lastsv-uc" select="str:replace($lastsv, '.', '-')"/>
<xsl:variable name="sv-uc" select="str:replace(standards-version, '.', '-')"/>
<li>The package should be updated to follow the last version of
<a href="https://www.debian.org/doc/debian-policy/">Debian Policy</a> (Standards-Version
<a href="https://www.debian.org/doc/debian-policy/upgrading-checklist.html#s-{$lastsv}.0"><xsl:value-of select="$lastsv"/></a> instead of
<a href="https://www.debian.org/doc/debian-policy/upgrading-checklist.html#s-{standards-version}.0"><xsl:value-of select="standards-version"/></a>).
<a href="https://www.debian.org/doc/debian-policy/upgrading-checklist.html#version-{$lastsv-uc}"><xsl:value-of select="$lastsv"/></a> instead of
<a href="https://www.debian.org/doc/debian-policy/upgrading-checklist.html#version-{$sv-uc}"><xsl:value-of select="standards-version"/></a>).
</li>
</xsl:if>
</xsl:template>
......
......@@ -32,8 +32,8 @@
<!-- Those variables controls the todo and problem item concerning
standards-version not being up to date -->
<xsl:variable name="lastsv" select="'4.1.5'"/>
<xsl:variable name="lastmajorsv" select="'4.'"/>
<xsl:variable name="lastsv" select="document('../base/d/debian-policy/unstable.xml')/source/standards-version"/>
<xsl:variable name="lastmajorsv" select="concat(str:split($lastsv, '.')[1], '.')"/>
<!-- lintian summary -->
<xsl:variable name="lin_errs" select="$other/lintian/@errors" />
......